I am following the tutorial for Creating a Lowpoly Concrete Barrier.

At about 29 minutes and 4 seconds he begins snapping the first two pieces of the texture in the UV map. I believe I have the settings the same and I managed to get the first vertex to vertex to snap. However when he snaps the right side it is multiple vertices to one vertex and the image seems to move instead of growing bigger (hard to tell b/c he is zoomed in).

The image below is the point I get to:

Uv unwraping

...however every time I try to snap this ends up happening (one vertex gets pulled and snaps versus all vertices moving and the lowest one snapping:

One Vertex

I have spent the last hour trying to find how to do it how he did in the video and I'm at a point where it's just become frustrating, but I don't want to give up. What am I missing? Thanks.

  • $\begingroup$ Works fine for me.. $\endgroup$ – gandalf3 Oct 18 '14 at 2:55
  • $\begingroup$ When I select using B and I pull down using the cursor it always pulls one vertex. Am I suppose to be holding something on the keyboard? Or is something wrong in my settings by chance? $\endgroup$ – CrazyGrunt Oct 18 '14 at 2:55
  • $\begingroup$ Ah, try grabbing by pressing G after selecting the vertices. $\endgroup$ – gandalf3 Oct 18 '14 at 2:56
  • $\begingroup$ I'm still very new to this. That worked perfectly. Thank you! $\endgroup$ – CrazyGrunt Oct 18 '14 at 2:58

Try using G instead. By clicking with RMB RMB, you are deselecting everything but the vertex under the cursor, which will then be translated.

Translating/grabbing with the mouse is sort of intended as a convenience thing to quickly be able to tweak individual vertices without pressing G.

The reason why it can't work for translating a selection of multiple elements is because RMB RMB is already used primarily for selecting. So clicking will first select the vertex under the cursor, then after moving the cursor 10px with the mouse button held, the grab/translate operator is called. This 10px threshold is configurable in ⎈ Ctrl⎇ AltU> User preferences > Input > Tweak Threshold:

enter image description here

In most places and most of the time you'll want to use G for translating/grabbing.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.