1
$\begingroup$

I am currently following Blender Guru's donut tutorial for 2.8, but I've had an issue with the material preview in the viewport. This seems to come from the donut, where the entire object simply pixelates with bright and blinding white pixels along with a few other rainbow colors. When moving my view around, the pixels leave a trail too. I don't know if this is an issue with switching from Eevee then to Cycles, or if it is something else. Here is how my issue looks like:

enter image description here

If I add back the icing and sprinkles:

enter image description here

When I zoom in and out:

enter image description here

Edit: Here are my computer specs:

  • Name: ALIENWARE13R3
  • Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60 GHz
  • RAM: 32 Gb
  • System: x64
  • OS: Windows 10
  • GPU: NVIDIA GeForce GTX 1060

Here is the blender file to download on MediaFire: Donut Tutorial.blend download

$\endgroup$
  • 2
    $\begingroup$ There seems to be something horribly wrong going on with your graphics pipeline. Could you share your .blend-file via blend-exchange.giantcowfilms.com so we can check if the errors can be reproduced on our hardware and share your system specs with us (OS, hardware, etc.)? $\endgroup$ – TheBeautifulOrc May 18 at 21:47
  • $\begingroup$ @TheBeautifulOrc Thanks a lot for dedicating your time to this. I added the specs to my question, and shared the link to a mediafire to download the file since the link you shared didn't seem to upload correctly my file. $\endgroup$ – scriptyshake May 19 at 9:16
0
$\begingroup$

So I opened your file on my machine and have to inform you that the glitches only occur on your end.

The doughnut looks just fine in my Viewport:

Viewport

And renders beautifully (this render was done with only 8 samples in about 7 seconds):

Render

Since you are using a laptop I suspect the switch between IntelHD-Graphics and your dedicated chip my be the cause of this problem. Since I'm not a Windows user I can only give you limited advice on this issue:

  1. Make sure all your hardware drivers are up to date.
  2. Start Blender with your GTX enabled (right-click on the application, then choose something like "run with NVIDIA")
  3. If that doesn't solve your issues and you're positive that neither your OS nor your hardware are at fault here, try filing a Blender bug-report.
| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much! I checked if my drivers were up to date, but the problem was still there. But then, I did "run with NVIDIA" for Blender, and the issue was gone! $\endgroup$ – scriptyshake May 19 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.