16
$\begingroup$

I have a brick wall that I am trying to add a door to. I have already UV mapped it, so when I move the loop cut to the right height, it distorts my UV map. How can I avoid having to unwrap it again? loop cut
loop cut with distorted UVs

$\endgroup$
0

1 Answer 1

24
$\begingroup$

Press G, G or Ctrl E > Edge Slide to move the loop cut. Then in the bottom of the Tool Shelf or by pressing F6 turn on Correct UVs.

edge slide

In Blender 2.9 it's now called Correct Face Attributes

Correct Face Attributes - screenshot

$\endgroup$
3
  • 1
    $\begingroup$ Also the inverse of this operation, once you've baked everything, you can remove the extra loops again using 'x' then 'g', this should preserve the UVs. Now your higher poly model once again becomes your low poly model. All the baked textures will still match up so long as you keep watching the UV coordinates and use 'Undo' should you ever damage a UV island when removing a loop. $\endgroup$ Oct 18, 2014 at 1:14
  • $\begingroup$ You can also use this technique to push loops up against each other and use remove doubles to merge the two loops. This helps with cases where the previous method fails. $\endgroup$ Oct 18, 2014 at 1:15
  • $\begingroup$ In Blender 2.9 and Blender 3.0, there is an option called "Correct Face Attributes", which allows you to preserve the UVs even when NOT edge sliding. However, when using Edge Slide, you still have the option to toggle "Correct UVs" on or off, however this option is NOT visible until after you first confirm the operation by left clicking. Then you can further adjust parameters, including the "Correct UVs" option. For example, if you wanted to dilate a pupil by edge sliding and have your eye texture stay locked to the iris, turn the "Correct UVs" option OFF. $\endgroup$ Feb 1, 2022 at 18:36

Not the answer you're looking for? Browse other questions tagged .