1
$\begingroup$

I am brand new to Blender. Currently creating donut with tutorial series from Blender Guru and immediately run into problem. Do you have any ideas how to get rid of these ugly artifacts in object mode?

enter image description here

$\endgroup$
  • $\begingroup$ can you send the .blend file? $\endgroup$ – Motcho May 19 at 19:47
  • $\begingroup$ Hello, thanks a lot for your willingness help :) Here is a link to the file ► drive.google.com/open?id=1R6V5Hm0AjLMBjC4Los5ZtDXMttssFsj_ I dont know why those artifacts are there. Maybe the problem is not in Blender, but somewhere else. When I tried this tutorial few month back, everything worked well without problem. $\endgroup$ – Jakub Vonsak May 21 at 15:49
  • $\begingroup$ I edited my original answer it should fix it but I do not know the cause of the issue tbh. $\endgroup$ – Motcho May 22 at 0:59
  • $\begingroup$ It works now! Sorry for my dumb question, but I have never had problems like this. Thanks a lot for your solution :) $\endgroup$ – Jakub Vonsak May 22 at 14:05
1
$\begingroup$

Use reasonable view port clipping range in your 3D view, please.

enter image description here

There are fixed amount of precision degree in view port (32 bit perhaps?). If you make the view port cover range too large (from 0.000001 to 1000), it will cause z-fighting in your scene.

If you're doing that infamous tutorial, use these setting should handle your scene correctly.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Always use 1/10 or 1/100 clip start value of the tiniest detail size in your scene to ensure the fine part won't cause z-fighting. It might be hard to understand why but that's how Computer Graphic work $\endgroup$ – HikariTW May 22 at 2:34
  • $\begingroup$ Yes, this was the reason. I set it up on 0,00000 something and it made those horrible artifacts. Just find out on my own and wanted to place an answer here, but see u already placed a solution. Hopefully it will help someone else too :) $\endgroup$ – Jakub Vonsak May 26 at 4:51
0
$\begingroup$

Enable Auto smooth enter image description here

Should fix it

Since this didn't work I took a look at your .blend and I have no clue why it is like that but I copied your donut mesh and pasted it into a new .blend file and it looks perfect enter image description here

Your .blend file is either glitched or you changed some settings. I tried pasting some of my personal meshes into your .blend file and the same artifacts appear.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.