0
$\begingroup$

[ New info and possible work around at the end of the post. ]

I searched for help but didn't find a solution for this.

Also, I'm sure this is not a Blender problem, it's a Umake app problem, but maybe you can help me to find a way to get around the problem.

Right now it would be very important to me to able to make some work using first Umake to create some rough ideas.

  1. I've exported some OBJ files from Umake, and I'm trying to open them in Blender. But the mesh created is not usable at all.

  2. I tried pressing ALT+J but that didn't help.

  3. Also tried to remesh but didn't fix it.

I'm new to Blender, can you tell me if there is a simple way to clean this up? It just want to have a simpler mesh. Alt + J seemed to do the job, but then I realized it did not.

UPDATE 1 - Found a workaround:

  1. Import the OBJ file.
  2. Go to "Object Data Properties > Geometry Data" and press "Clear Custom Split Normals Data".
  3. Press Alt+J to clean the mesh of triangles.
  4. Go to "Edit Mode" and "Select All", then do right click > Merge Vertices > By Distance.
  5. Press "F" (or do right click > New Edge/Face from Vertices).
  6. Do a remesh.

Now the object is "fixed" and it's safe to sculpt, etc.

So, Blender experts:

  • With this info can someone explain us what is happening with this kind of .obj files?

  • Can someone explain why those steps are neccesary to "fix" this?

  • There is a better/cleaner work around for this?

As I said before, I'm new to this. Understanding what is going on, and how this "fix" works is very important to keep learning Blender. I found this solution just trying dozens of tutorials founded on google and youtube, some how I was able to create this solution, but I'm not sure why this worked.

Thanks!

OBJ file on Dropbox

This is how the OBJ is imported:

This is how the OBJ is imported

After Alt + J

After ALT+J

But didn't work

enter image description here

$\endgroup$
3
  • $\begingroup$ @DuarteFarrajotaRamos thanks for helping me to format my post, I feel that this post it could be very useful for some people. Today exist a lot of 3D apps, and being able to go from one app to the other and be able to continue working ok is very important. $\endgroup$ – Newoldschool Jun 4 '20 at 23:18
  • $\begingroup$ Also @DuarteFarrajotaRamos, can you please not Close this post as Solved yet? maybe someone give us useful information about what is the origin of this issue and why this workournd works. Maybe there is a better way to solve this problem, thanks! $\endgroup$ – Newoldschool Jun 4 '20 at 23:19
  • $\begingroup$ It's a known and common problem. Not sure of the cause, but my guess is various apps store custom normals using different orientations standards. If you found an answer to your post you are encouraged to post your findings and answer your own question, but don't post it as an edit to your question, post it below as an answer maybe even gain some rep $\endgroup$ – Duarte Farrajota Ramos Jun 4 '20 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.