1
$\begingroup$

UPDATE: So resetting default preferences helped. But I checked the preferences file (not readable with editor). I then screenshot evry settings tab and compared with factory settings. There was no change then 1 addon: NodeWrangler. Deinstalling Nodewrangler didnt help, first the factory reset. So there must be a different option somehwere else which is also saved in the userpref.blend . Perhaps anyone else could imagine?


I followed BlenderGurus Beginner Tutorial, and in Part 4, Level 3: Realistic Liquid - Blender Beginner Tutorial I have following problem. In Viewport (Image right side) you can see the coffee shines more dark through the glass and has dark-reddish reflection on the plate/ground. In the Rendering the glass looks very greyish and there is a highlight reflection on the plate/ground as if there is some lightsource or coffee won't be rendered correct. The liquid is sized to fit between the both sides of the glass and I followed all material settings and couldn't find out where the problem is. Could you help me here?

Best Regards Sören

Text

It should look like this in Render: (from tutorial) Text

Update: After the Answer of @Jachym: Still same false behaviour for me: Text

Blender File:

$\endgroup$
  • $\begingroup$ No I am not sure. :) I did just everything like in the tuts. Could you give me a hint how to do ? $\endgroup$ – Sören May 17 at 17:26
  • $\begingroup$ are you using eevee or cycles? $\endgroup$ – Jonas May 17 at 17:32
  • $\begingroup$ I am using cycles $\endgroup$ – Sören May 17 at 17:34
  • $\begingroup$ I added a pic of the tut how it should look in rendering also (like in viewport). Not like at my setting, different shadows in viewport/rendering, and rendering looks unnaturally $\endgroup$ – Sören May 17 at 17:52
  • $\begingroup$ Hi again, @Jachym Michal I uploaded the file to my question. Sorry I missed that before ;) $\endgroup$ – Sören May 17 at 19:33
1
$\begingroup$

I checked your file and everything seems to be working fine.
With such low samples, Denoiser can introduce some artifacts, so perhaps that's what happened.

Viewport (64 samples) enter image description here

Render (128 samples) enter image description here

Render (128 samples) + Denoise Node enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Surely I have settings 64/128 and denoising node, but I downloaded the file and tried it again. still different result as you may see in the screenshot I added in the post. Some problem with settings? $\endgroup$ – Sören May 18 at 4:58
  • $\begingroup$ UPDATE: @Jachym Michal : If I download a new Blender Portable it renders correctly. So must be something with settings, but can you think of what it could be ? $\endgroup$ – Sören May 18 at 4:59
  • $\begingroup$ Hey :). This means it's probably something in your Blender Preferences. You can load factory preferences, and see if that helps. No idea what it could be though, sorry :). $\endgroup$ – Jachym Michal May 18 at 9:59
  • 1
    $\begingroup$ Perhaps someone else could imagien what setting it could be ? $\endgroup$ – Sören May 18 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.