0
$\begingroup$

So I have followed many tutorials on how to paint textures and it does work in simple objects, but not on a this sculpt. I can paint vertices and weight but not texture. I have tried to change to edit mode and back like suggested here: https://blenderartists.org/t/not-again-cannot-texture-paint-in-3d-viewport/532884 , no luck.

  • I can't paint in 3D or UV
  • I see the cursor I see my texture in the same color
  • it is connected to the model
  • I can flood fill and change
  • the color of everything (again proving that the texture is linked)
  • Mask is not activated
  • my normals are correct (I can not paint inside or outside)

but the brush does nothing.

/edit: here is the file as requested Texture tab showing my settings

$\endgroup$
  • $\begingroup$ could you share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots May 17 at 14:16
  • $\begingroup$ @moonboots, Thank you for mentioning that. I have uploaded the file and attached it to the main post $\endgroup$ – Holger Sontag May 17 at 16:30
1
$\begingroup$

There might be a new way to paint in 2.8 but for the moment your object doesn't have any material, so create a basic node chain like Image Texture (with your "main Okulossos Paint" image loaded) > Base Color input of a Principled BSDF > Material Output.

Now you still won't be able to paint, it's because you've opened a completely black texture for your brush, so close it and you'll have access to the normal color palet:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for the answer, but I can't really figure out what you mean. I can't find the nodes you are talking about. I checked tutorials on this, but they also give no indication of how this is done. Could you give me a bit more information? $\endgroup$ – Holger Sontag May 17 at 17:08
  • $\begingroup$ The nodes are in the Shader Editor window. You'll easily find tutorials on this topic, maybe for a former version of Blender but it hasn't changed a lot, example: youtube.com/watch?v=YNxmh5UVi08 or youtube.com/watch?v=7FobUOuISak $\endgroup$ – moonboots May 17 at 17:21
  • $\begingroup$ ah, shader, got it. The icon looks very different in my version. that is why I could not find it. $\endgroup$ – Holger Sontag May 17 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.