4
$\begingroup$

I have 3 render layers that I'm compositing together in the 4th one. Everything works fine, but even if I don't see the layer in some specific moment blender still renders it. The problem is that I use the Cycles volumetric light for a short time then it disappears and we don't see it anymore but it still takes forever to render even though every single light in the layer fades to black. How can I make it stop rendering what I don't need anymore?

P.S. I know, I can render it part by part and then composite a video, I can even render it with image sequence to not to lose any quality with re-encoding video, but it would be wonderful if it could be done withing blender compositor and animation system.

$\endgroup$
4
$\begingroup$

Renderlayers have a checkbox next to them which controls whether or not the renderlayer is rendered.

This checkbox can be animated (like most options in blender) by pressing I while hovering over the check box or by pressing RMB RMB> Insert keyframe to insert a keyframe.

Note that this will make the renderlayer node not output an image, so your compositing setup must be carefully designed to account for that.

If the layer you want to toggle has no alpha transparency, a simple alpha over node will let you put another image in place of the renderlayer when it is not enabled (in this example, I used a mask node to provide a solid color the same size as the render):

enter image description here

If the layer does have alpha transparency, this won't work.

Instead you'll have to use an animated mix setup or something.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks, I was searching exactly for this, but for some reason if I'm animating a render layer I'm getting a black screen, no matter if the state of render layer is on or off in the moment. I need to mention that I do use alpha and I'm not really using different render layers but different scenes. $\endgroup$ – Vitaliy Oct 17 '14 at 9:46
  • $\begingroup$ Just tried with non alpha layer and it worked fine, so alpha is the problem $\endgroup$ – Vitaliy Oct 17 '14 at 9:53
  • 1
    $\begingroup$ Can't think a way around the alpha but hey, instead I have animated samples count(God, I love Blender!) and dropped it to 1 at the moments when I don't need a layer and the other layers are working with your example, so now it is quite fast. $\endgroup$ – Vitaliy Oct 17 '14 at 17:29
  • $\begingroup$ if you also animate the factor value of the alpha over node you can use alpha transparency $\endgroup$ – Quacksilber Oct 13 '18 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.