-1
$\begingroup$

Whenever I press the F12 key or click render, then render image my image doesn't update. While making the scene yesterday it updated every time I hit F12.

This is my scene, you can see there is a green thing and some other stuff changed:

This is when I hit F12. No Green thing, no changes or updates:

$\endgroup$
1
  • $\begingroup$ I'm not sure if you've found a solution yet but I had the same problem. I fixed it by clearing all the images in the Video Editing tab. Hope it helps Cheers $\endgroup$ Aug 5 '20 at 12:26
1
$\begingroup$

I had the same problem a few days back and clearing the image sequence in the Video Tab fixed it for me.

  1. Go to the Video Editing tab in the top bar
  2. Delete whatever video or image sequence you have in there
  3. The preview should be empty now and you should be able to render the correct image

Hope this helps!

enter image description here

enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

There is a layers list in the top right of the screen without the render window open

Layer List Example

Try changing to the layer called "Render Layer". Blender will render each layer independently so they may be combined in the compositor. I'd recommend removing the layer which is out-dated to solve this or look into using the compositor.

It may be rendering into another image. By default it will render into an image called "Render Result". You can find this in the drop down menu at the top of the screen as shown below.

Image displaying the drop downs Location

$\endgroup$
3
  • $\begingroup$ Sadly, I did not find it in rendering in any of the images in the drop-down menu. :( $\endgroup$ May 16 '20 at 9:08
  • 1
    $\begingroup$ Are you using either: Compositor, Multiple Scenes, or Collections? $\endgroup$
    – Kieran
    May 16 '20 at 9:15
  • $\begingroup$ I'm new to blender, just 2 days. I don't know what the compositor is. I have just one scene and 3 collections: Scene Collection, collection, and collection 2. $\endgroup$ May 16 '20 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.