0
$\begingroup$

I know I sound crazy but try it. Doing this works perfectly in Object mode, but not in Sculpt Mode.

To reproduce:

  • Change the Pan View keybind from Shift + Middle Mouse to Shift + Left Mouse button.
  • Open Sculpt Mode and try Panning the View, panning the view will work in object mode, but not Sculpt Mode.

Some notes:

  • Right Mouse won't work either in sculpt mode, middle mouse is the only key blender will accept to pan the camera.

  • Alt + Left Mouse will work, but I need it to be Shift + Left Mouse.

  • I have looked through the keymap window for conflicting actions that use the same input, but couldn't find any.

I am just trying to setup sculpting for my iPad using the apple pencil, since the pencil doesn't have a "right mouse button" or "middle mouse button". If i can just fix this problem I will be home-free and able to sculpt on the iPad with blender.

$\endgroup$
  • $\begingroup$ Hi, welcome! IPad is not exactly a supported platform for Blender, but in some way I guess you managed to run it on the tablet (which, how?). Does this happen also on a regular desktop/laptop running a supported OS? If it happens anyway, it's probably a bug, and you could report it to blender devs, probably nobody before you noticed this. If it works on a supported OS, but not on IPad, I guess something could be not compatible for some reason with your tablet system. $\endgroup$ – m.ardito May 15 at 21:04
  • $\begingroup$ Sorry, I should have specified. Duet app on iOS lets you treat the iPad as a second monitor in Windows with apple pencil support. This problem is still a problem even if we disregard the ipad entirely and I'm just using blender on windows with a mouse and keyboard. Thanks for the reply :) $\endgroup$ – Cole Aguirre May 17 at 17:18
1
$\begingroup$

Yes,it can be done. But probably what prevents you to do so is: there's already another "shortcut" using the same combination in Sculpt, by default.

if you search for "sculpt" in preferences, you'll see that there are three different mouse/keyboard combinations to do the "sculpt" action, including this:

enter image description here

you can remove it by clicking on the "x" icon right of it, getting this:

enter image description here

then, if you set you desired "pan" shortcut in the "sculpt" editor section from the default:

enter image description here

to:

enter image description here

you should be able to "pan" the sculpt view with your preferred combination, like I was able to do here:

enter image description here

By the way, remember to save your preferences to keep this configuration or it would reset at next start. You can also reset to factory settings in the same menu.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much, Do you have any idea why I'm not able to use a custom key modifier with the left mouse? I was able to use your suggestion and get it to work in sculpt mode, then, when I tried a custom key modifier such as F5 + Left Mouse. It woudn't work. Your answer was perfect. Thank you. $\endgroup$ – Cole Aguirre May 18 at 19:16
  • $\begingroup$ Thanks, happy to hear that it worked :) No, I tried but function keys like F5 can work alone, but they're "regular keys", not "modifiers" like CTRL, ALT or SHIFT instead. You could set "pan" to be executed while F5 is pressed, and simply move the mouse (no clicks) to pan, though. Just keep F5 pressed and move the mouse (having the focus on the area of course). Release F5 and it doesn't pan anymore. $\endgroup$ – m.ardito May 20 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.