0
$\begingroup$

I have a problem with eevee render: it shows the metal reflections in the viewport but not in the final render. What is wrong?

enter image description here

enter image description here


Moving the camera away helps, but the metal on the object still has no reflection maybe I should have an background image to reflect something...

enter image description here


This changes not much. I post my shader settings I followed in a tutorial earlier maybe the problem is there.

enter image description here

$\endgroup$
  • $\begingroup$ Hey :). There seems to be some reflection. Perhaps move your camera a bit farther to see more of it. $\endgroup$ – Jachym Michal May 15 at 16:33
  • $\begingroup$ To get similar reflections as in your viewport, use HDRI as environment texture :). $\endgroup$ – Jachym Michal May 15 at 17:53
0
$\begingroup$

Yes,I feel nothing to reflect might be your problem.

You can use an HDR to check reflections and lightings. Just a google search would help, or just go to https://hdrihaven.com/ or http://www.hdrlabs.com/sibl/archive.html

You can get some free HDR and just plug the .exr into "world" shader-node.

This would solve issues if some are there with your scene itself.

You can also try checking the screen-space reflections box in the render options. Might help. I would uncheck half-res to hoping that no half-res makes it full-res.

Screen space reflections

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.