3
$\begingroup$

The question is: how do I get rid of these particular seams? I've found a few tutorials on removing seams in UV mapped textures, but these all seem geared specifically towards matching textures that actually don't show gaps. In this image, you can see the seams near the bottom, appearing white. In the past, I have caused them to be black or grey, by having "render alpha" unchecked.

In my UV map, everything looks reasonably correct: the image is 1024x768px, with each "frame/cube-side" being 256x256px. Some of them match up fine, others seem to leave a few-pixels-wide gap. With the UV map, I have checked to make sure the map isn't picking up any unused areas of the texture. The UV map bounds the image perfectly.

Is it possible that this is a bug in the UV map stuff, causing it to pick up a pixel or two of the unused transparent areas of the image? Or is it something I'm doing wrong.

UPDATE: These lines appear exactly on the same edges as the seams I marked. This makes sense, taken with the fact that it's rendering transparency. Why this happens, I don't know.

$\endgroup$
1
$\begingroup$

UV's are used to define a link between a 3d surface and a 2d surface. When a colour is needed for the 3d surface it finds a location in 2d space and then chooses the nearest pixel from the image. While rounding floating point numbers and choosing the nearest pixel from the image there can be slight variations while following the edge between two points. While texture painting may get drawn to the left, the renderer may choose from the right.

For this reason it is common to bleed the texture colour past the visible edge of the UV's so that there is always a valid colour to be chosen. This means you need to leave some space between islands when laying out your UV's.

When texture painting there is an option to set the amount of bleed, it's location is probably a bit misleading as it is found within the project paint settings.

enter image description here

$\endgroup$
  • $\begingroup$ How do I access "Project Paint"? All of the resources I found show just the small panel, but I don't know where that panel is to be found. $\endgroup$ – user7519 Oct 16 '14 at 15:03
  • $\begingroup$ It's in the 3dview tool panel on the left (press T). Newer versions with tabs will have it under the Options tab and it's only visible while in texture paint mode. $\endgroup$ – sambler Oct 17 '14 at 12:32
0
$\begingroup$

I found an easy fix for this was to change my texture interpolation to "closest". I had no need for texture interpolation for my scene (which was just a dummy scene to convert skyboxes to equirectangular panoramas), so in this particular case removing texture interpolation was the best solution.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.