I'm fairly new to Blender and I'm trying to make a teddy model and I want to wrap the arms around the body (Like how when you drop cloth on a ball, it forms to the shape of the ball where it lands)

This is what I have at the moment:

enter image description here

However, the red arm is a flat plane so when i try to attach it onto the body some of the arm either goes into the body or is too far from it:

enter image description here

So I need it to be curved to the same curve of the body where it joins on.

I've tried using the shrink wrap modifier but that just makes the hand go deformed and when I get it in the right position it doesn't follow the curve of the body anyway.

I've tried making a curve and manually created points following the curve of the body and using the curve modifier on the arm and setting it to the curve.

I've tried using the simple deform modifier on the arm and selecting curve and curving it however, this just sort of twists it in a weird way.

I've also tried creating a uv sphere (thinking it might be the fact that the body is actually a cube would effect it) and trying the shrink wrap modifier for that but it still has the same effect.

In case it's not clear what i'm trying to do here how it is now from a top view: enter image description here ... and here's what I want to achieve: enter image description here

The body is a cube that I have used a subdivision modifier on and adjusted (It is not a sphere) and I made the arm by creating a curve, setting the spline type to poly and manually placing each point to form the shape, then converting it too a mesh and filled in the face.

It's probably something really stupid i'm missing but I would be very grateful if you could help.



  • 1
    $\begingroup$ Shrinkwrap works best when there is enough geometry both in the target object and the modified object. Try to add more geometry to your arms so that it can bend. In your case you should set the shrinkwrap method to "project" along the X axis. $\endgroup$
    – Gorgious
    May 14, 2020 at 18:28

1 Answer 1

  • Create a plane, subdivide it, put it between your sphere and the arm.
  • Give your plane a Shrinkwrap modifier with the sphere as the Target. Disable the modifier visibility for the moment.
  • Give your arm a Surface Deform modifier with the plane as the Target. Click on the Bind button.
  • Enable the plane's Shrinkwrap visibility.

enter image description here

  • $\begingroup$ Hi, thanks for your reply. I've used the shrinkwrap modifier on the plane with the sphere as the target and that worked. I've also bound the arm to the sphere using the surface deform modifier but the arm is still flat and hasn't curved. @moonboots $\endgroup$
    – Saul Batts
    May 14, 2020 at 19:31
  • $\begingroup$ you need to click on Bind with the plane's modifier visibility off (disable the screen icon in the modifier), then turn it on, did you do that? $\endgroup$
    – moonboots
    May 14, 2020 at 19:33
  • $\begingroup$ Thank you, this worked :) $\endgroup$
    – Saul Batts
    May 18, 2020 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .