11
$\begingroup$

I guess I pressed a hotkey by accident and my keyframes disappeared for whatever reason. As far as I can tell the keyframes are hidden by the frame numbers numbers:

enter image description here

The animation still works, I can add new keyframes, but I cannot select any of them as they're hidden... Does anyone know how to get back to the default settings?

$\endgroup$

4 Answers 4

13
$\begingroup$

Middle click in the timeline then drag your mouse down.

I don't know why you can infinitely scroll keyframes up in this case. Sometimes they disappear and you have to drag down for quite some time to get them back.

enter image description here

$\endgroup$
1
  • 3
    $\begingroup$ Strange behaviour indeed. Matkers are overlaid it seems. View > View All will bring all kfs to view. $\endgroup$
    – batFINGER
    Commented May 14, 2020 at 13:50
9
$\begingroup$

With mouse cursor over your Timeline press Home on your keyboard or go to View > Frame All:

enter image description here.

Same trick applies for Dope Sheet (and pretty much any other view in Blender).

$\endgroup$
4
$\begingroup$

Another possibility why you can't see the keyframes on the Timeline might be, if you've enabled the option Only Show Errors in the View menu of the Timeline window, than your keyframes will not show up unless there is an error.

timeline view options

$\endgroup$
3
$\begingroup$

In Blender 2.8, I had to uncheck Only Keyframes from Selected Channels from the View menu. Keyframes reappeared for me.

enter image description here

$\endgroup$
1
  • $\begingroup$ Since the accepted answer was already given about 1.5 years ago and the object which keyframes "disappeared" was selected, this answer does not really bring any new benefits to the question... $\endgroup$ Commented Nov 3, 2021 at 10:50

You must log in to answer this question.