0
$\begingroup$

I am trying to make a 80's style grid mountain valley animation with the scene slightly animated by a noise texture displacement.

However when some deformed faces cross a certain point they "snap" either up or down creating a very distracting and bad looking effect.

I have made the initial mountains by applying a noise texture to a plain and modifying it to create a valley path for the camera which resulted in some faces being distorted or "bent" by having two opposing vertices below the other ones, this creates a jumping or snapping effect when the displacement makes the geometry cross the threshold of the "bend" being in the opposite direction.

Is there any way i can fix this? Like, disabling the snapping, or making it always face one direction without manually readjusting 150k+ faces?

$\endgroup$
2
  • $\begingroup$ What about using triangles instead of quads? Also do you have smooth shading turned on and autosmooth disabled? $\endgroup$
    – Bruno
    May 14, 2020 at 11:22
  • $\begingroup$ I tried using trianbles, it helps but then all of the squares in the grid have an additional line through the middle and tht's not the effect i'm looking for ;p I just enabled smooth shading, it was previously off as well as autosmooth and doing a test render with smooth shading enabled and autosmooth disabled. @edit: faces are still snapping with smooth shading on $\endgroup$
    – fimeq23i
    May 14, 2020 at 11:25

1 Answer 1

0
$\begingroup$

I have converted my mesh into triangles and used this to wireframe it instead: https://www.youtube.com/watch?v=67Q2Z4vVrMI&t=588s It seems to have resolved the issue.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .