2
$\begingroup$

As seen in this tutorial, adding a Waves modifier to a subdivided plane results in multiple concentric ripples - and that's the behavior I remember from versions of Blender prior to 2.8.

However, when using 2.8 and adding a Waves modifier to a subdivided plane, I seem to get only a single wave which deforms the plane, even when editing the Width and Narrowness etc values.

How can I recreate the earlier behavior with the current modifier? Sorry if this is a dumb question, I've been messing about with the modifier and I'm somewhat baffled.

EDIT 01: It seems like I can get something close to the behaviour from the video with the following settings - but they're fairly extreme. Am I missing a 'frequency' setting or something? enter image description here

EDIT 02: I downloaded 2.77, as this is the version Gleb was using in his tutorial (linked above) and the Waves modifier works identically to how it works in 2.8, requiring extreme values to create multiple ripples.

But in the tutorial video, Gleb just brings in a new plane, subdivides until there’s 66,049 verts and adds the modifier… and voila: enter image description here

Default values, no changes to width or narrowness and yet there are the desired ripples…!

I’m baffled.

I think I’m going to have to chalk this one down to gremlins.

$\endgroup$
5
  • $\begingroup$ You need a very low Width value in order to see multiple waves, have you tried that? $\endgroup$ – moonboots May 14 '20 at 6:35
  • $\begingroup$ Yep - as demonstrated in my edited question. That's weird, I thought I edited that fairly fast, but folks are responding as if they didn't see my addition. Hmm. Thanks for the comment, @moonboots - Do you think the 'low Width value' is intended behaviour or could it be a bug? $\endgroup$ – Reverend Speed May 14 '20 at 14:50
  • $\begingroup$ it looks like it worked the same way in 2.7, I don't know why they set this value this way $\endgroup$ – moonboots May 14 '20 at 14:54
  • $\begingroup$ Well, to clarify, then, do you think that the values set in this manner is an 'error'? Or at least worth raising with the dev team? $\endgroup$ – Reverend Speed May 14 '20 at 15:14
  • $\begingroup$ it must have its reason, it refers to the unit, but it should be corrected so that by default its much higher, because it doesn't fit with the default size of a plane $\endgroup$ – moonboots May 14 '20 at 15:16
0
$\begingroup$

The Wave Modifier seems to be somewhat broken (or at least very unintuitive).
It works best with larger objects, and doesn't scale very well.

Here is an example of my settings on a 1x1m plane, just to help you out.
I couldn't make it work on a smaller plane.

enter image description here

And while this image from Blender Manual is sweet, the manual's reccomended settings don't seem to work well either.

enter image description here

$\endgroup$
1
  • $\begingroup$ This tracks with my experience. I should mention, I did manage to achieve the effect I was looking for (if you look at the edit to the question above), and had taken note of the sweet image from the Blender Manual. Given this behaviour, do you think this is worth reporting as a bug - or at least as an error? $\endgroup$ – Reverend Speed May 14 '20 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.