-1
$\begingroup$

I've tried every imaginable combination of Roll value and "Inherit Orientation" for both parent and child both Before and After creating the child.

When I create my child bone (a horizontal one) and try to Bone Constraint it with "Limit Rotation"

and all Axi limited with Z limited at -90°, +90° it just faces the other way.

How do I get the child to understand that 0 degrees for it is supposed to be "North" not "South"?

It just utterly refuses to face the way I choose.

No matter how many times I recreate it or it's parent. or start from scratch.

This is armature view, as you can see , the roll is set to 0 same for parent : tank side

This is the pose mode view, simply adding the values to Transform lock rotated the bone backwards. if I then test posing I can bear witness to it allowing rotation at the back face of the tank and preventing rotation at the front face. It is reverse to what I want and not even godly powers could make it otherwise as far as I can tell : tank above

I started from scratch again. still the same thing : in action

Even if I rotate the entire set of bones 180° (with R) either in object or edit mode, and reposition them to the tank mesh in Armature it still flips the turret bone when I enable Z rotate limiter.

$\endgroup$
1

1 Answer 1

1
$\begingroup$

Once you give the Limit Rotation constraint to your bone it rotates the bone to its 0/0/0 rotation position because by default the constraint is set to the World orientation. You need to switch the Convert setting to Local Space, or Local Space With Parent.

$\endgroup$
1
  • $\begingroup$ World Space is the wrong default for bones. Take note blender devs. $\endgroup$
    – tatsu
    May 13, 2020 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .