I've made a tank model,

kinda futuristic so there is actually less rigging to do (the idea is a tank that has 4 treads that are each rotating at their joint with the body at the outermost. this would somewhat compensate terrain deformation, it could also allow for a "partform-sniper-mode", anyways) , the way I see it there should only be 7 bones. One for each part of the tank :

tank model

And as you can see I've thought ahead and made a separate mesh for each part.

My first attempt at rigging went porly, I had correct joint rotation but despite my meshes being separate the bones brought along some of the closest bits of the next mesh as they moved. which made the tank look more jello then steel...

Here's what I did :

First I added transform constraints on the bones as inspired by : https://blender.stackexchange.com/a/116376/95840 this answer is critically outdated because that UI no longer exists in Blender 2.8 but it set me on the path of looking for the equivalent to bone transform constraints in 2.8. which I stumbled upon haphazardly in this video : https://www.youtube.com/watch?v=1_LcXcNnieQ

Where in the first 15 seconds he sais these are applicable to meshes and bones alike and then goes on to ignore all those viewers who would have loved to know how you access that menu for bones which is not visible in either edit mode, object mode or bone creation mode.

But I figured it out, you use the edit pose mode which you access though ctrl-tab (when no mesh is selected?)

which reveals an extra menu, called "bone constraint" : bone constraint

form which you can add transform constraints

Once my transform constraints were added to all the bones I then moved on to merging the bones with the meshes.

Which I did by selecting all bones (A), ctrl-P, select "Armature with envelope weights", then I went into pose mode, and first selected one segment, shift-select the corresponding bone bone, ctrl-P and click "bone", I did this for each segment.

So where did I go wrong?

Ideally I would want the bones to alter no trigs on movement.

I'm fine with the meshes spinning independently of one another. I modeled them that way so it would seem natural.


1 Answer 1


the solution is all of the above plus:

while you have a bone selected :

bone selected

in the third-to-last little tab with the same green bone icon :

bone menu

untick "Deform" like so :

deform unticked

Do this for every single bone that mush not deform meshes (in my case all the bones)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .