3
$\begingroup$

I'm dealing with a professionally authored fbx file of a quadruped. It has been created using max.

This is what the rig looks like in 3ds max:

enter image description here

I import it using the option "Automatic bone orientation" in Blender 2.81.

What I see then is this:

enter image description here

The pelvis is rotated to the side, and "RigLShoulderBlade" and "RigRShoulderBlade" point towards each other.

I have tried all other (non automatic) bone orientation options, they were even weirder than the automatic option.

How should I deal with this?

I have uploaded the animation fbx in question here.

It would be very nice if somebody could tell me how to import it in Blender in such a way that the bones are rotated as in 3ds max.

Thank you very much for the help!

Edit: I have filed a bug report at blender.

$\endgroup$
3
  • 1
    $\begingroup$ Regardless to this thread developer.blender.org/T53620 Pre-Rotation is not working as supposed to. But disabled Pre-Rotation seems to operates with armature orientation (not bones) hmm. AutomaticBoneOrientation tries to find right orientation somehow, but not perfect as you can see. I'm not so experienced here, but what I tried and saw - your result is almost perfect from others :) Manual is filled more by notes than how-to ... docs.blender.org/manual/en/latest/addons/import_export/… If you can - export and import as DAE $\endgroup$
    – vklidu
    May 17 '20 at 15:12
  • $\begingroup$ Thank you, it works for pure animation files in DAE, but not for DAE files with skin. Actually, I wanted to use the skin / mesh of the model, too, not only the animation. When I try to import a mesh in DAE format, blender doesn't do it. I still need to figure out why. $\endgroup$
    – tmighty
    May 18 '20 at 22:50
  • $\begingroup$ I tested DAE with no skinning problems from Mixamo (actually the same weight paint resulted better in extreme poses). I'm not experienced with 3DSMax. $\endgroup$
    – vklidu
    May 21 '20 at 7:21
1
+50
$\begingroup$

enter image description here

I don't know why exactly this is happening (I'm using 2.82a and having the same issue), but since you have so few bones which are misaligned, I find that I was able to go into Edit Mode and manually adjust them in less than five minutes.

Regretably, this is not the answer you were hoping for. But it seems to work.

$\endgroup$
4
  • $\begingroup$ Thank you. Does rotating the bones not change the skinning? $\endgroup$
    – tmighty
    May 20 '20 at 12:34
  • $\begingroup$ I never saw any model in what I imported. Only bones and animation. If there is a model also, I didn't see it, nor do I know why. But the animation seems to work the same way, both before and after this adjustment. So it's possible that the skin will be unaffected. If it is affected, it can most likely be fixed with weight painting. Not ideal, but at least afterwards, you can continue with your project. $\endgroup$
    – R-800
    May 20 '20 at 12:39
  • $\begingroup$ It may be worth pointing out that the importing and exporting of file types between programs can often have all manner of conversion difficulties. Sometimes we have to work with what the software gives us. In your case, you seem to have quite a lot going right in your file after the import. It could have been much worse. $\endgroup$
    – R-800
    May 20 '20 at 12:45
  • 2
    $\begingroup$ @tmighty Editing the bones in edit mode does not change the skinning. $\endgroup$
    – Leander
    May 20 '20 at 12:54
0
$\begingroup$

Fixing bones in edit mode is possible (it does not affect skinning).
But transform "Pelvis" bone in Edit mode affects final animation.

Here overlaped your armatures with armatur with edited pelvis (blue).

enter image description here

Note: "Automatic Bone Orientation" works in some cases, but fails in some others for me. FBX differs from app to app. If you want to re-orient all bones with the same rulle due import to blender's orientation - in your case worked ...

Manual Orientation > Forward Y / Up Z
Armature > Primary Bone X / Secondary Bone Y
and uncheck "Use Pre/Post Rotation"

enter image description here

It does not fix your issue (same as your import), just in case you want to see FBX axis translated to Blender's axis. Here are edited root and shoulderblade bones.

Pelvis is kept as imported = animation fits to your original animation.

enter image description here


Example in this blend:
- Armature.001 (AutoOrient) - imported FBX with Automatic Bone Orientation feature
- Armature.002 (AutoOrient+Pelvis) - imported as previous plus Pelvis snaped to tail in edit mode = animation differs
- Armature.003 (Manual) - manually set axis in import option plus ShoulderBlades changed in edit mode (untouched pelvis bone) = animation fits original

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.