0
$\begingroup$

For this first post, I wand to detail a weird issue for my character model. I am new to IK rigs, and I just finished my character. The armature has absolutely no problem. After having parented the model to the armature with Automatic Weights, here's what it looks like.

enter image description here

Hovewer, as soon as I try to move a single leg, here is what happens :

enter image description here

The fist leg does not follow the IK bones, and the other leg stretches abnormally, and the chest follows the deformation. I have absolutely no clue what causes this. I could create a weight map, but my character's UV map has gone crazy too. Should I fix something using the IK parameters?

NOTE : I got several issues while mirroring the bones to the other side. The control bone was absent as I forgot to add .R at the end. I finally fixed this glitch. I think the problem is rather model-related, as the armature does not have any problem.

I can send the .blend file if you wish.

Thanks for your answers.

$\endgroup$
  • $\begingroup$ yes please share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots May 12 at 13:06
  • $\begingroup$ I am sharing it. Sorry for the waiting time $\endgroup$ – AnewAnimator May 12 at 13:33
  • $\begingroup$ you need to correct the parentage in Weight Paint mode. Your mesh is very high-poly, why don't you keep it low-poly? It might help... Also, are LegFull.R and L supposed to influence the mesh? Because you've let their Deform option enabled... To make the Weight Paint easier, in the Edit menu (top left) disable Lock Object Modes, now you can select both the mesh and armature and switch to Weight Paint mode $\endgroup$ – moonboots May 12 at 14:31
  • $\begingroup$ too bad you didn't keep a low-poly version, but you can simplify this one easily. For parentage correction you can both use the Weight Paint mode and the Assign button under the Vertex Groups list (Properties panel > Object Data > Vertex Groups) $\endgroup$ – moonboots May 12 at 15:59
0
$\begingroup$

Thanks a lot for this answer! however, how can I correct the parentage?

P.S. I cannot modify it back to high-poly, because older versions of my model are gone. I will try to weight paint now.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ please don't use the Your Answer field, it is made to give an answer, not to comment ;) $\endgroup$ – moonboots May 12 at 15:57
  • $\begingroup$ Hello and welcome. Please don't add thank you as an answer, upvote the answer instead. If you feel it completely solved your problem consider marking it accepted $\endgroup$ – Duarte Farrajota Ramos May 12 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.