0
$\begingroup$

I'm trying to fill a water bottle in blender but when I set it as effector the fluid from the fluid source passes directly through it, I don't know what to do help.

Here is the blend file

$\endgroup$
1
  • $\begingroup$ Your bottle is non-manifold, that's probably the main cause of the problem. Also your bottle is a quite heavy mesh, you should use a simplified version for the simulation (then replace it by the heavy one for the render). Also, your domain seems larger than necessary, so you loose a lot of resolution. $\endgroup$
    – thibsert
    Commented May 11, 2020 at 21:58

1 Answer 1

2
$\begingroup$

@thibsert is correct: bottle had a gaping hole at the bottom, which I clumbsily sealed by adding a cylinder.

Also...

The Collision Effector surface thickness has to be at least 0.5 Thickness, which I have reported as a bug. And I have no idea why the default Sampling Substeps is '0', when I find that is often insufficient. This also (unfortunately) implies that you'll have to have a duplicate, 0.5*2 larger scaled (hidden) effector, if you want to fluid to touch the sides and bottom of your bottle (workaround for the bug).

You also had "Use Effector" disabled, so it was ignored by the simulation. I also increased the Domains Resolution Division, and decreased the particle size: often a pair of culprit contributors to poor results.

here is the resulting blend file:

enter image description here

$\endgroup$
1
  • $\begingroup$ Nope. Still doesn't work on Blender 4.2. $\endgroup$ Commented Apr 3 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .