2
$\begingroup$

How can I pack exactly 1 specific file into the .blend on Blender 2.82?

In external data, I have many texture files. Some I use in all my .blend files and a few I only use in this .blend file.

Example:

scene1.blend
    wood.jpg (packed into scene1.blend)

scene2.blend
    marble.jpg (packed into scene2.blend)

sky.jpg (not packed in any blend file)
plastic.jpg (not packed in any blend file)
$\endgroup$
3
  • $\begingroup$ My usual method (vers 2.77) for all packed files including video, is to zip them up and add an EMPTY -> Image. Open the folder icon and select the zip file. If not zipping, most files will be accepted individually except video files. I change the extension on those. $\endgroup$ – Edgel3D May 11 '20 at 5:36
  • $\begingroup$ @Edgel3D Can you give more details? I did: shift+a > empty, go to "object data properties", select my image, add fake user, and save blend file. The image is not packed into the blend file. $\endgroup$ – chhdgxhuc May 14 '20 at 1:09
  • $\begingroup$ The details were a little too large for comments so I've dropped them below as an answer. Hope that clears things up. $\endgroup$ – Edgel3D May 15 '20 at 10:28
1
$\begingroup$

Create a fake user.

(From the blender manual:)

Since zero user data-blocks are not saved, there are times when you want to force the data to be kept irrespective of its users.

If you are building a blend-file to serve as a library of things that you intend to link to and from other files, you will need to make sure that they do not accidentally get deleted from the library file.

Do this by giving the data-blocks a Fake User. This prevents the user count from ever becoming zero: therefore, the data-block will not be deleted (since Blender does not keep track of how many other files link to this one).

Go into the image editor and click on the shield-looking icon:

enter image description here

Fake User (shield icon) Keeps the data-block saved in the blend-file, even if it has no Real User. When activated an “F” will be shown before the name in the list.

Once a fake user has been created, the image can be packed into the .blend file.

An alternative use the outiner, enable the blend file browser, select the image and create a fake user for the image.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Following your two methods, I cannot get the blend file to pack only the single image file. When I save the blend file, either no images/textures are packed, or all of them are packed. $\endgroup$ – chhdgxhuc May 14 '20 at 1:04
  • $\begingroup$ Sorry to downvote, but this in not an answer to the question. Creating fake user only prevents a reference to image from being deleted, while the question is about including whole image (and only one specific image) into the .blend file so that it can be stored inside of it instead of along with it. $\endgroup$ – int_ua Jul 27 '20 at 21:50
0
$\begingroup$

I've had to add this as an answer, it's too large for comments...

I'm talking vers 2.77 here but you should see the same or similar options in 2.8+. The keys I use are SH-A then select --> "Empty --> Image" . An Empty square plane will appear. In it's properties at right, select the tiny image icon. Open the file tab click on 'Open' and select the file.

To recover - open the same icon and tab again, click on the file LOCATION folder-icon. It's under the open file icon.

Select the "Create" option, (the 2nd option on mine) and that will create a "Textures" folder in your project folder. In there the recovered file will be present.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.