I've read several questions and answers and none seem to apply to me. I want to make a wall with a cutout for a door. Using Blender 2.8, here are my steps:

  1. Create a new 'general' file
  2. The starting cube will be my wall. Since I live in a backward country, I don't do meters. Instead, I'll type units as inches. So I scale the cube to 4.5 m in the X direction (the wall is 4.5 inches thick), 120 meters-as-inches in Z direction, and oh, let's say 240 inches in Y so that it's 10 feet tall and 20 feet wide.
  3. I move the Z location of the wall to 120 so that a Z of zero is the floor
  4. Great! I have a wall!
  5. Make a door with Shift-A, add Mesh->Cube
  6. Scale it to 6, 30, 80 to make a door 30 inches wide, 80 inches tall, and thick enough to use as a boolean difference object. Set the z-location to 80 to bring it up to the floor
  7. I select the first cube and Add Modifier. Select Boolean, difference, and the doorway object
  8. Click Apply
  9. Select the doorway differencing object, hit G and X to move in the X direction to move it out of the way to see the hole in the wall, and...
  10. There is no hole in the wall. Why?

I'm 100% certain that this is user error. I just don't know what error I'm making. Can anyone show me my mistake?

After moving the differencing object out of the way


First off, you can set the unit system to imperial instead of metric under Scene Properties > Units > Unit System > Imperial, and set the Length to Inches.

enter image description here

When you're using real system, do not change the scale value. Instead, press N and go into Dimensions. Here you can set the values. You can see the difference between scale and dimensions in this picture. You can also type in other Imperial units, such as ft. This will automatically put it into feet. Math operations such as *( multiplication) or / (division). It's really handy.

enter image description here

Now add the cube. Again, use the dimensions panel to get the correct size of the door. Go into side view by pressing 3 on the numpad, press G, hold CTRL and bring it up to the floor. For the door zoom in so you can see the smaller squares and do the same. Make sure you're using the increment under snapping settings.

enter image description here

I tried exactly what you've done and ran into the same issue. Yet the solution is pretty simple! With the door selected, press TAB to go into edit mode, select the bottom face and drag it down by pressing G, then Z and dragging it down a little bit. Then press TAB again to leave the edit mode and press S and X to scale it on the sides.

enter image description here

... but that's just in case you come to something like this again. Otherwise the simplest solution would be to make it thicker and move the bottom a little bit right when you're scaling the door! :P

Then repeat what you did - add the Boolean modifier, select the door as the cutter, operation to Difference hit apply and you're done! You can now also delete the door if you want to.

enter image description here

If you also want to fix the topology after boolean operation (which I would highly recommend), select the corner of the door hole and the corner of the wall and press J. Repeat this on each side so you have quads all around the mesh. We don't want any ngons there!

enter image description here

Hopefully a bit longer and more detailed reply was worth it. Happy Blending! :)

  • $\begingroup$ Thank you! That's like half a dozen lessons in one post! I appreciate the time you took to explain the various concepts. $\endgroup$
    – Nevo
    May 10 '20 at 18:49
  • $\begingroup$ You're welcome! And I've made a huge typo that's fixed now - by typing ft it won't give you inches, but obviously feet. But I'm pretty sure you got the idea. :-) $\endgroup$
    – Drax
    May 10 '20 at 20:36
  • $\begingroup$ I also tried to cut doors out of a room (Blender 2.8.3). The cube ended at z=0, as did the room and it only gave me a couple of edges (like op). Covering the bottom edge with the cube did it, thank you so much! $\endgroup$
    – Neph
    Oct 27 '20 at 16:06
  • $\begingroup$ Something I have to add after failing again today: Don't forget to check if 1. the normals of the object are good (Viewport Overlays - Normals - Display Normals), 2. there's nothing that's non-manifold (in edit mode: Select - Select All by Trait - Non Manifold) and 3. there are no double vertices (in edit mode: Mesh - Clean Up - Merge by Distance). Usually 3. fixes 2., as long as there are no "open" faces. $\endgroup$
    – Neph
    Oct 28 '20 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.