0
$\begingroup$

I would like to create an “outer glow” to Suzanne the monkey so that It emits some red and purple lights (and the plane should reflect them).

To illuminate the monkey, I added the Emission shader and there are two cases:

  • Using low strength values keeps the colors but it doesn’t emit enough light.

  • Using high strength values emits the required light but the colors of the monkey change!

Changing the bloom settings is not a good idea for me as it affects the lighting in the whole scene and other glowing objects.

I tried to use Light Path node but it didn't help or maybe I didn't know how to use it properly. enter image description here enter image description here I need to emit light with the same red and purple colors (not yellow and purple with white line separating the two colors). How can I solve this?

$\endgroup$
6
  • 1
    $\begingroup$ Hello :). Meshlights in Eevee are considerably limited: blender.stackexchange.com/q/99631, blender.stackexchange.com/q/101244 $\endgroup$ – Jachym Michal May 9 '20 at 20:33
  • 1
    $\begingroup$ Just to add - Light Path node is also limited in Eevee. $\endgroup$ – Jachym Michal May 9 '20 at 20:36
  • $\begingroup$ It's not the emission shader. It's the color transform. Sorry, if you want to change bloom, you need to change bloom settings, and adjust your other objects to match, or else use multiple render layers. $\endgroup$ – Nathan Dec 17 '20 at 21:28
  • $\begingroup$ blender.stackexchange.com/questions/46825/… $\endgroup$ – susu Dec 18 '20 at 0:49
  • $\begingroup$ Hey,I would suggest you to just turn off the bloom in render settings and then add it after rendering in compositing. This way, you can get desired color with Suzan and still be able to control bloom in compositing. $\endgroup$ – Raj jaiswal Apr 28 at 1:54
1
$\begingroup$

added a comment but I think it's an complete answer. So, here's what you can do.

Turn off bloom settings in eevee and use emmision strength of just 1.

Now,render the thing. After that,go into the compositing tab and click on use nodes. Add in a flare node just before output node. Now you can use bloom effect without changing the mesh's colour.

You can watch this video if you had any problem using glare node- https://youtu.be/SN8nJXn7CqI

$\endgroup$
0
$\begingroup$

I guess there is more than one way to do this. I would have tried a RGB-Curve node with a Vector-Math multiplier before and probably after to tweak things (dial back the Green). Skip the color ramp and mapping nodes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.