0
$\begingroup$

I'm having a really hard time trying to keep the color I have on my characters arm while baking the color of it. The problem is that when I bake a "Combined" bake type with Diffuse, Glossy, Transmission, Subsurface, and Emit selected (No direct nor indirect lights), The results came out black. I found out the reason is because the disconnected "Emission" value's color is set to black on the Principled Shader's BSDF on the arm I'm baking from.

If I change that color from black to anything else, then I can definitely bake it and the color shows up, but changing the Emission color also messes up the arm color I've worked hard to set up on my character. I tried plugging the Mix nodes' color output into the Emission value's input, I tried adjusting all the color ramp colors, but I've noticed that changing the Emission color from black to anything else messes up the color. How can I keep the same color I have and bake it exactly as is; Do I need to change my node setup?

enter image description here

$\endgroup$
1
$\begingroup$

If you need the pure color (formerly known as "diffuse", today it's called "albedo") without any influence of light, you don't use the Combined Bake. You can leave your setup as it is, you just have to make sure to not catch any light influences (shadows, reflections, etc.)

This means you have to bypass the Principled BSDF and pass the color values directly to the material output. You can do this by routing whatever node connects to the Base Color of the Principled BSDF through an Emission Shader directly to the Material Output.

Adding Emission node

If you have the Node Wrangler add-on installed, you can simply do the same by pressing Ctrl+Shift + Left-click on whatever node connects to the Base Color of the Principled BSDF.

Using Node Wrangler to add Emission Node

In the Bake Options you select "Diffuse" as Bake Type, under "Influence" you deselect "Direct" and "Indirect" and leave "Color" selected.

Bake Options

No need to delete any nodes or create separate materials for each bake. Just reroute whatever you want to bake to the Material Output.

| improve this answer | |
$\endgroup$
-1
$\begingroup$

The way that worked for me was to delete the Principled BSDF Shader and insert a Diffuse BSDF instead. Also Instead of baking Combined which is incorrect, I then was able to set the bake type to "Diffuse" with no light contribution at all and I got the correct color to bake. The other answer mentioned above is the better way to go however since I'm new to this.

| improve this answer | |
$\endgroup$
  • 3
    $\begingroup$ If you need color, you should bake color and not combined.Combined is a mix of color, light information as well as information coming from material properties. I downvoted the answer, because it may be misleading to someone who might stumble upon it. It needs more detail and clarity. $\endgroup$ – Martynas Žiemys May 8 at 18:07
  • $\begingroup$ Just changed it to make it more clear for anyone who finds this. Thanks $\endgroup$ – Ernesto May 8 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.