1
$\begingroup$

I hope someone can help me with this weird issue.

I'm trying to create a sphere that emits fire, like the sun. I've followed this tutorial.

This is what it should look like:

enter image description here

However, as soon as I copy the object (sphere, forcefield and domain) into my other project, the sun's flames start to look like this:

enter image description here

When I copy the object out into a new project, (after baking of course) it again looks good.

What could this be? I've spend dozens of hours trying to figure it out, recreating it etc, but it always comes down to this.

I would greatly appreciate anyone's help! :)

I'm using Blender 2.8 and rendering in Cycles.

EDIT: I re-created the sun following the guide, using a new General blender project. This is the result (which is good):

enter image description here

Now, I've copied that object into my other project.

I didn't change the position or size, and simply rebaked. After bake, this is the result:

enter image description here

Puzzled as to which settings leads to those blurry, small flames. At best my end result is this, which seems pretty low res compared to the earlier creation:

enter image description here

As far as I know, I haven't changed anything special with regards to the project settings, but I'm more than happy to try some suggestions / check some settings if anyone has an idea :)

Thanks in advance!

$\endgroup$
  • $\begingroup$ So you're saying that sun looks problematic when copied into the project you're making, but has no problems when it's copied to a new project. i.e. the problem is only when it's copied to your project. $\endgroup$ – Manu G May 7 at 13:21
  • $\begingroup$ Hello Manu, So it seemed at first, yes. I also tried with another guide who supplied a .blend file (blender.stackexchange.com/questions/71461/…). When opening that example, it looks nice and sharp. So, I copied my 'defect' sun from my project into that one, and it looked nice and sharp as well. I even tried copying the example (the blueish fireball) into my own project, and again, it is blurry. I don't change anything on the position or size, I simply rebake. $\endgroup$ – KrazeyKami May 8 at 8:49
  • $\begingroup$ Just to be sure, I'm recreating a new General blend file as we speak, and following the 'sun guide' once more. I'll edit this comment and place examples in the main thread once the bake is done. $\endgroup$ – KrazeyKami May 8 at 8:53
  • $\begingroup$ I've posted the results. Again the weird blur. $\endgroup$ – KrazeyKami May 8 at 9:43
0
$\begingroup$

I 'solved' this by doubling the resolution of the domain. Still puzzles me why I have to for a same-sized object, and only in this project.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.