I have a Voronoi texture using object coordinates and a Vector Math node set to Add to translate the texture along the Z axis. This works fine! However, if I use another texture (Noise, Musgrave, Image, whatever) to control the Scale of the Voronoi for a type of distortion, as I translate the Voronoi, the distortion becomes more intense the more I translate, as if I were increasing an "Intensity" factor.

This is the result before translation: This is the result before translation

This is what happens when the image is translated: This is what happens when the image is translated

EDIT: After some further tests, I now see that this happens with all the built-in procedural textures; Voronoi, Noise, Musgrave etc.

EDIT: I get the same results even when using a Mapping node: Here's the result when using separate nodes Here's the result when using a mapping node

This happens in both Cycles and Eevee in 2.8, 2.81, and 2.82, which makes me think this is not a bug. Is this correct behaviour, and if so, could someone explain why this happens, please?


  • $\begingroup$ Hello, could you add a screenshot of your node setup ? $\endgroup$
    – Gorgious
    Commented May 6, 2020 at 9:58
  • $\begingroup$ Sure! I guess I should have done that in the first place. $\endgroup$
    – gcs_dev
    Commented May 6, 2020 at 10:07
  • 1
    $\begingroup$ Scaling of procedural textures via the Scale input happens relative to the origin of the chosen coordinates (object coords in this case). The further you move from the origin, the more extreme the effect of scaling will be. $\endgroup$
    Commented Nov 20, 2021 at 8:55

1 Answer 1


The problem is that you are translating in the z-direction which is not useful when we are working with 2D textures like voronoi, noise, musgrave, etc. In 2D space, we can only go in the positive x and negative x and positive y and negative y-direction i.e. left, right, up, down. The Z ins't important since the z-axis is used in 3D space, not in 2D. However, for rotation using the mapping node, we do use only the z-axis to rotate although I don't know how that works. But when you translate, you can only use the x or the y parameter. If you use the z, it will disturb things instead of translating. Instead of adding to the z, add to the x or the y. That should work.

  • 2
    $\begingroup$ Voronoi, Noise, Musgrave etc. are not 2D textures. In Blender 2.82 and above they can be set to be 1, 2, 3, or 4 D but in no version of Blender are they 2D Textures by default. Even if this were the case, translating a 2D texture along the Z axis (assuming the texture uses X and Y) should not visibly alter the texture at all. $\endgroup$
    – gcs_dev
    Commented Oct 20, 2021 at 13:30
  • $\begingroup$ Thank u so much for the clarification! $\endgroup$ Commented Oct 20, 2021 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .