0
$\begingroup$

I made a new Blender file and added Quick Smoke to the default cube. I changed the renderer from Eevee to Cycles and switched to GPU Compute. When I render, all I see is the cube; the smoke doesn't appear. I've tried switching the cache type to Final and rebaking the sim and nothing changes. When I save the file and close and re-open Blender, nothing changes, and if I rebake after that, nothing changes.

Viewport: enter image description here enter image description here

Render: enter image description here

I should note that while I am on 2.9 alpha, this happens in 2.82 and 2.83 beta as well.

Before this gets marked as a duplicate, I've tried everything listed on other questions on this site and on Google that I could find.

$\endgroup$
10
  • $\begingroup$ Make sure the cube is disabled from being rendered (camera icon) and your domain has a proper shader (eg. a principled volume) applied. Also, don't forget to bake the sim. $\endgroup$
    – brockmann
    May 5, 2020 at 20:27
  • $\begingroup$ If i see it correctly you are using 2.9 .. thats currently in Alpa state... Maybe try a Stable version. $\endgroup$
    – J.Doe
    May 5, 2020 at 20:53
  • $\begingroup$ @J.Doe Edited; it happens in 2.82 stable and 2.83 beta as well. $\endgroup$
    – atirit
    May 5, 2020 at 21:09
  • $\begingroup$ Here is my quick take on it: blend-exchange.giantcowfilms.com/b/JYajA7v5 Renders fine on 2.8x... Can you test it? $\endgroup$
    – brockmann
    May 5, 2020 at 21:30
  • $\begingroup$ @brockmann That file renders fine for me: imgur.com/9GrkCjR. Let me try using Modular instead of Final in my file. $\endgroup$
    – atirit
    May 5, 2020 at 22:08

1 Answer 1

0
$\begingroup$

make sure that you didn't disable render for the domain. enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .