2
$\begingroup$

For some reason whenever I use a screw modifier my normals are being destroyed. The below image is before applying screw modifier enter image description here

Now after adding screw modifier, it looks like this enter image description here

I have made sure all the transforms have been applied. Is there a way to correct this quickly?

$\endgroup$
3
  • 1
    $\begingroup$ I think for that the screw will always give bad result, because it creates edges between the start and end of the mesh at every iteration. You can see it for yourself if you lower the Angle below 360°. What you need is either an Array modifier + Rotated empty or an array modifier + a curve modifier $\endgroup$
    – Gorgious
    May 5, 2020 at 12:57
  • 1
    $\begingroup$ Hey :). Screw modifier works best with single edges and no faces. Reduce the mesh to a single edge, and it will work very well. $\endgroup$ May 5, 2020 at 13:39
  • $\begingroup$ Ok, thanks! it worked with edges :) $\endgroup$
    – JacksonPro
    May 5, 2020 at 14:49

3 Answers 3

2
$\begingroup$

For anyone who might have the same problem. The screw modifier doesn't work well with faces. So have only edges or vertices when adding screw modifier enter image description here enter image description here

Here is a workaround for that problem if you really want to use the screw modifier with faces.

  • step1: select your object
  • step2: Add screw modifier
  • step3: add solidify modifier
  • step4: play around with offset and clamp in the solidify modifier until you get normal in the right direction.

enter image description here enter image description here

$\endgroup$
2
  • $\begingroup$ Hello :). Check Calc Order and your normals should work fine straight away. $\endgroup$ May 6, 2020 at 16:19
  • $\begingroup$ Well I tried and it didn't $\endgroup$
    – JacksonPro
    May 7, 2020 at 2:56
2
$\begingroup$

Just to add to the existing answer.

You can control face orientation in the Screw modifier.
By checking Calc order (corrects normals) and using the Flip option (flips normals).

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ yes this works with edges but not with faces $\endgroup$
    – JacksonPro
    May 7, 2020 at 7:42
0
$\begingroup$

If your mesh or part(s) of your mesh have flipped normals, here is what you can do :

  • Select your object and enter Edit Mode
  • Activate the Calculate Order option in the Screw modifier tab
  • Select the part of the mesh which shows flipped normals
  • Press the Space Bar(or F3) and search for the Mirror (X/Y/Z Local) function
  • Expand bottom left Mirror menu, then Orientation and choose Normal(instead of Local)
  • Find the axis that works for you (X, Y or Z)

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .