0
$\begingroup$

I've downloaded a .fbx model from Sketchfab along with a folder with several textures contained in .png files. I am not sure how to load the textures after importing into Blender. All of the models show up black. There are several options under "Material Properties" to choose from, but when I select one and connect it to a .png texture file via "Base Color," nothing happens: picture of Blender showing model with no textures

I am new to Blender but seemingly understand the basics of how textures/materials work. Still, I wouldn't be surprised if I'm missing something simple.

$\endgroup$
0
$\begingroup$

Duarte's comment got me to google some more, and I found someone who recommended replacing the Principled BSDF node in the Shader Editor with a Diffuse BSDF. This fixed it: Replacing Principled BSDF shader with Diffuse

Happy to get it working, although to be honest, I'm not sure why this worked.

$\endgroup$
  • $\begingroup$ You can still use the principled shader, just plug the output of the image node to the base color socket. And the BSDF output to the Surface input socket of the Material output. $\endgroup$ – susu May 5 '20 at 19:50
  • $\begingroup$ That is actually how it was before, in the image with everything blacked out. $\endgroup$ – cgoldberg May 5 '20 at 20:07
0
$\begingroup$

Quick-shortcut: Sketchfab has a blender plugin that directly imports the model into blender and handles everything for you (mostly)


Long answer:

As the post mentioned by the user (Duarte) that replied to your first question says, the way FBX, OBJ, or other 3d formats work is based on the mesh itself, the way materials work vary on the rendering platform you're using.

The material part of the rendering comes from the implementation that each renderer uses, even between Eevee and Cycles, both inside blender, you may have to adjust your nodes when switching (there are eevee only nodes and there are cycles only nodes, you can check those out here. FBX is a proprietary format by autodesk and can be a little bit finnicky to get it 100% with blender since blender is open source.


Getting back to your first post, when you downloaded the model from sketchfab if it was a FBX, did it come with two folders "Source" and "textures"? Something like this after extracting: vehicle-renault-12 extracted

If so, when importing FBX into blender, there are some options to mark: enter image description here If you look on the right side, there's Image Search, if checked, blender will check for images that might be associated with the fbx file, check if that works, if it doesn't, it might be worth to try recreating the material in blender again. When you download the model from Sketchfab, I think the fbx file assumes all textures will be in the folder "textures" next to source.

This is what happens when you import the fbx without the same file structure, in this case i removed the Images folder to recreate your issue: enter image description here

The model is black because there's nothing connected to the output, and if I connect those nodes to the output it just turns pink, hinting that the texture is missing, so getting back the textures, your folder might look like this:

enter image description here

The name of the files hint at what you must connect to the principled BSDF node, I won't get into how those work since that's another topic, but taking my example for instance, it'll look like this:

enter image description here

Another tip that some people might not know, if you enable the node wrangler addon (integrated with blender) you can click here and select the textures in the textures folder that came with the model: enter image description here

I hope it helps, fbx can be tricky to work with sometimes, if you post the link to the sketchfab model in question i'll try to help you if the above does not work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.