0
$\begingroup$

I created a diffuse material in the node editor in cycles on a UV-unwrapped standard default plane from a noise texture.

Then, I added a displacement modifier and in the texture option, there was exactly one option. I wanted to exactly match that noise texture, but it doesn't. No matter what I do, the changes I made to the material node editor have 0 effect on the displacement map, which begs the question: where the hell is this displacement map from?

$\endgroup$
3
$\begingroup$

There are two forms of displacement texture. One is the Displacement modifier, which is a modifier and runs off of a texture. You can edit the texture by clicking the checkerboard-like icon when you have the Displacement modifier open. For that, you can choose a noise texture if you want, and there are some parameters you can apply. You could also choose the "image" option, to load an image of the noise texture you're using.

A better option for you, though, would be to use the "displacement" option in the material node editor. The final node in the editor has three inputs: Surface, Volume, and Displacement. Plug your noise texture into a Displacement node (from the Vector section), and connect that to the Displacement input. Then, in the settings for the material itself, set the Displacement mode to "Displacement Only" or "Displacement and Bump". The change won't be visible in layout mode, but it will be visible in render mode.

EDIT: To help with clarity, here's a screenshot indicating the "edit texture" option when using the Displacement modifier. To be clear, the "checkerboard icon" I was referring to is circled in red.

enter image description here

Here's a screenshot indicating the menu within the texture edit panel where you can control what type of texture you're using. It does not interface with the node editor, to my knowledge, but you can use an image of your noise texture. To be clear, the menu is circled in red.

enter image description here

Here's a screenshot presenting the node setup I suggested. There's no red circle in this one; I hope you're able to figure it out anyway.

enter image description here

For the "Displacement Only" and "Displacement and Bump" settings, go to the Material edit pane (in the panel on the right, where you found the modifiers), then the "Settings" section, and then the "Surface" section within that section. Please note that this option will not appear if you do not have "Cycles" selected as your renderer.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Most of what you said lacks an incredible amount of necessary detail to be even remotely followable. Luckily I've already spent enough hours on this to know that nothing you said helps in any capacity. None of those options produce a reasonable and controllable displacement from the material node's texture. The displacement modifier works fantastically in Blender Render. If the cyclers coder isn't incompetent, there is no reason for it not to work in cycles too. $\endgroup$ – AskingRandomQuestions May 5 at 1:02
  • 2
    $\begingroup$ @AskingRandomQuestions I've edited my question with some images which I hope will help. I understand that Blender can be frustrating; however, I'll also draw your attention to the general etiquette surrounding posts and comments on this site, some of which you can read about at stackoverflow.com/help/behavior. A specific and polite request for clarification would have been much more likely to receive a helpful response. $\endgroup$ – Reese May 5 at 1:46
  • 2
    $\begingroup$ @AskingRandomQuestions Once again I'd strongly advise you change your tone and attitude. If an answer doesn't help either politely state why, or simply thank the user for the time spent trying to help you and move on. Personal attacks and and useless rants will not be tolerated here. $\endgroup$ – Duarte Farrajota Ramos May 5 at 2:24
  • 2
    $\begingroup$ @AskingRandomQuestions Given the nature of your responses here, I will not be responding further to this thread. Before I step back, though, I feel compelled to point out that other questions and answers (e.g., blender.stackexchange.com/questions/112160/…) have addressed the issue of the missing displacement node. A likely culprit is that you may have an earlier version of Blender. 2.79b and 2.8 have the relevant node. $\endgroup$ – Reese May 5 at 3:16
  • 1
    $\begingroup$ "The site blatantly lies all the time" made my day. Don't take it serious it's most likely a bot. You have done good work here @Reese $\endgroup$ – brockmann May 5 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.