7
$\begingroup$

I have tried using the Subframes option. It hasn't done a thing.

So I have an object which gives off 3 particles into the air. I have an Icosphere object on a different layer with a particle instance modifier on it. That allows me to add a particle system to the Icosphere to create some awesome particle trails

CLUMPING IS BAD

But the particle system that is attached to the Icosphere creates clumps of particles on each frame. I am wanting a nice, smooth stream of particles being emitted from the main particles.

Is there a way to fix this, or does the Subframes option not work with the Particle Instance modifier.

Here is my .blend file: https://db.tt/DhdNlo3h I am using Blender 2.72

$\endgroup$
  • $\begingroup$ @user2859 I am using 2.72 $\endgroup$ – Nathan Craddock Oct 12 '14 at 14:56
  • $\begingroup$ I see what you mean now. As a workaround you could stretch the time of everything by 10 and divide the timestep of the particlesystem by 10. Example. Would this work for you? $\endgroup$ – user2859 Oct 12 '14 at 17:48
  • $\begingroup$ How would I go about doing that. The image looks great! $\endgroup$ – Nathan Craddock Oct 14 '14 at 1:44
8
$\begingroup$

To increase the accuracy and smoothness of simulations it can sometimes be helpful to scale the time up.

Here a simple way of approximately stretching the time by 10. For every Particlesystem (3 in your example) multiply the End and the Lifetime of the emission by 10.

emission

and divide the Timestep of the physics by 10.

timestep

In render settings multiply the End Frame and Frame Step by the same amount (10).

render

And render the frames as images. For videos you can reimport the frames in the VSE as image strip and render with the desired fps.

Before and after time stretching

$\endgroup$
3
$\begingroup$

Another, more simple solution is to just make a longer emitter object. The emitter has to have more of a tube like shape, aligned to the path, and should be at least twice as long as the gap you get from the frame steps. The result of this method is pretty good.

$\endgroup$
2
$\begingroup$

as secrop said :

The problem is not with the particles! they are being created at subframes.. The problem lies on the FollowPath constrain, as it looks like it doesn't set a motion to the object but places the object each frame in a certain position. (thought motion blur is working ok :/)

The way to fix this, is to bake the FollowPath animation.

In the 3dView menu > object > animation > bake action ; check 'visual keying' and 'clear constrains' and bake data to object.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.