4
$\begingroup$

When I try to render a glass material, in rendered view it looks good, but when rendered, I get this wavy effect and black outlines.

enter image description here enter image description here

Polygon detail:

enter image description here

The scene is just a glass object with a glass material, background with a texture with a Diffuse shader and a lighting setup of two plane emissions.

  • Glass: 4 levels of subdivision surface modifier.

  • Background: 4 levels of subdivision surface modifier.

  • 2 plane emissions, with no modifiers.

  • 80 samples.

What is causing that and how can I fix it?

Here's the file if anybody wants to explore it.

$\endgroup$
6
$\begingroup$

The subsurf modifier on the glass object is disabled in the render.

Make sure the camera icon the subsurf modifier is selected:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks for the answer. The icon is selected, but the object renders as if it is not. I get the same result when I uncheck it, It renders as a low poly object regardless of the icon setting, pretty weird. $\endgroup$ – Vladimir Oct 11 '14 at 21:48
  • 1
    $\begingroup$ @Vladimir It's not selected at all for me in your file, but selecting it fixes it just fine.. Are you sure you have the right object selected? $\endgroup$ – gandalf3 Oct 11 '14 at 21:50
  • $\begingroup$ Yeah, I just saw that. I selected the background instead, my mistake. Thanks. $\endgroup$ – Vladimir Oct 11 '14 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.