2
$\begingroup$

I already searched the internet but could not find a solution to this. Maybe it is the same question as Why my animation render is getting greyish? but there was no answer.

I want to render a video with tracking, but the output "loses" color information and gets kind of greyish. I first thought that it is related to the renderer, but it happens in Cycles and Eevee. Therefore i made a sample image, added it to the image sequence editor and rendered it as 1 frame. Resulting in the same problem.

I placed the original image beside blenders output so that you can see the difference. The only idea I came up with is that something with the lighting is not correct but I can't find a setting for that.

I am using Blender 2.80 with the default settings. Only set the output resolution to match the input resolution.

the original and the processed image

$\endgroup$
4
$\begingroup$

Why is this happening?

The image's colorspace, and the color space that blender is using to display them are not the same.

Images displayed in a different color space will always look wrong

The values for what you call "white" are different depending on the color transform you use in the color management section.

If you are dealing with video files only, using sRGB values, and not rendering anything that uses a wide dynamic range, then you don't need "filmic", which is the "default" option on blender.

Set the View transfrorm from Filmic to sRGB (or "standard") in the color management section. To understand the difference read the following links:

White background with filmic blender

and

Render with a wider dynamic range in cycles to produce photorealistic looking images

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for your fast response - your answer solved the question! $\endgroup$ – nioerd May 2 at 18:54
1
$\begingroup$

Two things to keep the white... well, white.

  1. Connect your image texture directly, without a shader (to get rid of shadows)
  2. Change View Transform to Standard (to keep the max RGB values of white)

(Note: This will reduce some dynamic range and photorealism.)

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for your fast response and the video too - your answer also solved the question! $\endgroup$ – nioerd May 2 at 18:55
  • $\begingroup$ Happy to help :). Good luck with your project. $\endgroup$ – Jachym Michal May 2 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.