1
$\begingroup$

When I import an image as plane with the alpha channel for transparency, and it is in front of a background or reference image I can't see the object (plane) to place or edit it? Why is this?

If this is a duplicate question please link / flag, I have looked but can't seem to find an answer... Thank you for any help you can offer.

$\endgroup$
2
$\begingroup$

This happens because Images as Planes addon automatically uses Alpha Blend mode.

Switch to Alpha Clip or Alpha Hashed and it will work as intended
(You need to be in Eevee, for these options to show up.)

enter image description here

$\endgroup$
3
  • $\begingroup$ Yes that does it Jachym thank you! In fact I looked back at my notes and had made a note about this to use Alpha Clip when working with the Images as Planes Add On, but strangely (frustratingly) in this scene the Blend Mode wasn't there in the Material Settings. After a bit, I finally worked out that I had set the Render Engine to Cycles, which doesn't allow one to then change the Blend Mode under Material Settings. If I switch it to Eevee, make the change to Alpha Clip and then back to Cycles it keeps the settings. Weird... $\endgroup$ – Aubrey May 2 '20 at 16:17
  • $\begingroup$ Yeah, it's not very intuitive. Anyways, mad props to you for keeping blender notes :). $\endgroup$ – Jachym Michal May 2 '20 at 16:25
  • 1
    $\begingroup$ Haha Yea It's the only way I can learn the software properly, otherwise I keep checking the same tutorials again and again and asking redundant questions here. Cheers for taking the time to upload the .gif super helpful! $\endgroup$ – Aubrey May 2 '20 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.