0
$\begingroup$

Example of the problem: I have 5 objects and 1 armature. Every mesh is skinned to 1 bone and got 1 vertex group, but when I open this ".FBX" in unity and hit 'show all bones', it tells me that every mesh is skinned to every bone what could be the reason for this? I know the problem is in Blender. Opened the ".FBX" in Maya as well and its the same. Tried all kind of exports and cleans and still nothing.

enter image description here enter image description here enter image description here

$\endgroup$
6
  • $\begingroup$ I did not check, but I know from the past, that Blender FBX exporter is weak and can imagine it adds a 0 weight to non assigned deform weights. Why are the 0 weights a problem? $\endgroup$ – Leander May 1 '20 at 14:07
  • $\begingroup$ lets say that I want this FBX to be separated to 5 or even more prefabs in Unity... I want every mesh-prefab to have only the bones that it needs...It just makes my job easier after that. $\endgroup$ – Mario Musov May 1 '20 at 14:15
  • $\begingroup$ not sure that I follow...what 0 check? $\endgroup$ – Mario Musov May 1 '20 at 14:33
  • $\begingroup$ In unity, check wether the weight associated is 0? $\endgroup$ – Leander May 1 '20 at 14:33
  • $\begingroup$ Its easy to find out which bones control which mesh... I just remember them.. the problem is that I want to delete the bones that do not control the current mesh in the prefab $\endgroup$ – Mario Musov May 1 '20 at 14:38
-1
$\begingroup$

There is an option to export only deform bones in the FBX exporter.

enter image description here

For this to work you must uncheck the Deform option in the bone properties.

enter image description here

$\endgroup$
4
  • $\begingroup$ its not that.... I'm talking about deform bones... I've edited my post with 2 pictures... on the first will see 5 object skinned to 1 armature each object has 1 bone that is skinned to and each object has only 1 vertex group....but on the second one will see this FBX in Unity... and Unity says that every object is skinned to every bone... $\endgroup$ – Mario Musov May 1 '20 at 22:03
  • $\begingroup$ That's working as intended. When you skin a mesh to a bone it is influenced by every ancestor bone in the hierarchy. If you dont want this influence, unparent the bone. $\endgroup$ – Xtremity May 1 '20 at 22:22
  • $\begingroup$ it's not about parenting... its about weight $\endgroup$ – Mario Musov May 2 '20 at 5:43
  • $\begingroup$ I've added a 3rd image ... where you can see an FBX that comes from an other software... and you'll see how every mesh is skinned only to 1 bone... everything that is 0 weight is not shown in Unity and I can easily remove them from the prefab without breaking it... $\endgroup$ – Mario Musov May 2 '20 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.