1
$\begingroup$

I wanted to create a coffee and foam on top.

I used Blender Guru's donut tutorial. I saw how he made the coffee and foam, but I can't get things quite right.

The coffee looks dark on the top but the rest of it is light (transparent like water)

The foam in a distance (image) it kinda looks like one but things seem to be off (maybe the reflection or something causing it?), in another perspective it looks like there is no foam.

Here is two images I took (image of the coffee (screenshotted it since rendering it is slow) and the nodes/part of the material properties):

Render Result

Node Setup

Here is the actual file:

If anyone can see and help what's wrong, I will appreciate it! Thank you!

$\endgroup$
5
  • 2
    $\begingroup$ You can embed images directly into your post, and blend files can be included in your post using blend-exchange.giantcowfilms.com $\endgroup$ – stphnl329 May 1 '20 at 3:58
  • 1
    $\begingroup$ I believe you need to recalculate normals for your coffee, Blender Guru does that somewhere during the tutorial $\endgroup$ – stphnl329 May 1 '20 at 3:58
  • $\begingroup$ @stphnl329 I don't remember where that is and none of the other stuff I searched up help. Can you tell me how to do it if you know? Thanks! $\endgroup$ – Rue May 1 '20 at 19:26
  • $\begingroup$ also, I saw when I turned on face orientation, everything seems fine. It's all blue, which is the correct way. IDK what to do next... $\endgroup$ – Rue May 1 '20 at 19:40
  • $\begingroup$ Enable auto smooth normals on the coffee! $\endgroup$ – stphnl329 May 1 '20 at 22:20
0
$\begingroup$

You need to enable auto-smooth normals. The reason why the coffee is being shaded so weirdly is because you've enabled smooth shading which averages out the normals. As a result, some of those flat faces start getting the strange shading as if they were a curved surface.

enter image description here

So go to Mesh Data > Normals > and enable Auto Smooth. Then increase the angle slightly so that all of the rounded faces that should be smoothed out are smoothed out. However, if you increase it too much, it'll start smoothing out the top face again and you'll end up with the strange shading again.

enter image description here

Edit:

You also seemed to have forgotten to delete some of the geometry from the cup object. that intersecting with the liquid is probably part of the reason why it looked so weird. And please turn down the viewport subsurf modifier on the cup down from 6...there is no reason why that cup should have millions of verts. enter image description here

$\endgroup$
6
  • $\begingroup$ I fixed the things you mentioned except for one...I found out when I turned off my coffee liquid, the liquid is "still" in it. When I hid my coffee cup, The "liquid" is turned off. So that means that the cup is sealed with a top layer. That is probably why...What should I do in this case? How can I fix it and delete the top layer of the cup? Coffee liquid on: link Coffee liquid off: link $\endgroup$ – Rue May 2 '20 at 0:49
  • $\begingroup$ Actually I figured out, I used autosmooth on the cup too and deleted the extra faces. It looks better but...it's kinda still the same but the top is lighter. link What should I do in this case? How can I make the color more like coffee, and make the foam on top of it. (extra, I want the steam to make it look hot too lol) $\endgroup$ – Rue May 2 '20 at 1:03
  • $\begingroup$ Keep watching the tutorial :-) youtube.com/… Be patient, the tutorials will cover all that in due time! As for steam, finish up the rest of the donut tutorial first, then look up how to do a smoke sim in Blender. Good luck! $\endgroup$ – stphnl329 May 2 '20 at 1:07
  • $\begingroup$ I did both, well...I tried to rewatch the part I need and followed my best. It didn't really work. For the steam, I did search it up, but some things are more different. So I'm not sure...I have tried and done it before, didn't work out so I came here...do you know how to help about this or is this all you can do? $\endgroup$ – Rue May 2 '20 at 1:13
  • $\begingroup$ What isn't working? What's is it looking like? If you'd like, my Discord is stphnl329#8530. I really can't troubleshoot from a few lines of text. Not sure if you're trying to be rude ("is this all you can do?"), but the Blender SE is better designed for Q/A of specific issues, not tutorials. $\endgroup$ – stphnl329 May 2 '20 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.