0
$\begingroup$

I can't seem to figure out these rigid body settings. A group of objects are parented to an empty, and I want the empty to bump into the ball and make it roll. I'd like that to be repeated a few times. I tried to put a rigid body constraint on the empty and select both the ball and the body of the figure (blue shape in red) but still nothing. When I do just put a rigid body on the blue shape and ball, they both just float away.

enter image description here

$\endgroup$
0
$\begingroup$

They are going to float away because they don't have a floor. Make a plane (size it to however big you want) and apply the rigid body to it, making it passive instead of active. Place the plane just below your objects.

After that, you should animate the blue object to hit the ball. Click "animated" in the rigid body settings for the blue object then animate it to hit the ball. You can animate the blue object to bump into the ball as many times as you want, but make sure that the ball stays on the plane. If you hit the ball too far, it will fall off the edge of the plane.

$\endgroup$
4
  • $\begingroup$ Thank you both for the quick responses. It looks like the blue shape needs to have the animated settings, but the ball should not. The ball is moving, but not rotating like it naturally would. How could I control the distance the ball goes, and the rotation? Is it the "mass" and "rotation" within the dynamics settings? $\endgroup$ – Mason Apr 30 '20 at 22:05
  • $\begingroup$ I think you should change the values for mass, if I'm not mistaken. That should impact how far it rolls as a heaver object would take more force to get it moving faster. $\endgroup$ – CStafford-14 Apr 30 '20 at 22:11
  • $\begingroup$ I've got it working, but it never stops rolling throughout all of the frames, and also won't rotate at all. The mass settings don't effect the ball. I tried adjusting both the blue shape and the ball but nothing. $\endgroup$ – Mason May 1 '20 at 14:16
  • $\begingroup$ The ball has a flat material with no texture and smooth shading has been enabled. It doesn't appear to be rolling, but it is. You might want to adjust the ball's friction to be higher, but aside from that, I'm not sure what to do. $\endgroup$ – CStafford-14 May 2 '20 at 16:28
0
$\begingroup$

The ball and the "blue shape" should be set as rigid bodies, the box empty should not. They're currently being pulled downwards by the default gravity force; you can disable it in the "Scene Properties" tab.

enter image description here

With that out of the way, in the Physics tab set the "blue shape" as an animated rigid body by clicking the checkbox under the Settings submenu. Assuming the empty is already animated, it should give you the desired result.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.