0
$\begingroup$

I am trying to make a beach. When I tried simulating the fluid (2.82 mantaflow), it went mostly well. However, I noticed that the water would stick to the entire floor when all I wanted is that around 2/3 of the ocean floor is covered.

enter image description here

As you can see there is a sloped down part, and I want some section of it to not be covered by water. However, it seems that if the water touches something, it will never recede from it leading to this unrealistic simulation.

I baked it at 100 resolution and then baked it as a mesh to make it easier to see. If you need more information please request it.

$\endgroup$
0
$\begingroup$

After playing around with the settings I tried enabling Fractional Obstacles inside the Liquid settings in the physics tab. This solved the issue for me. I think that the reason things like this were happening was that the obstacle was represented as a bunch of voxels, so in the fluid's perspective, it looked like a bunch of stairs. Checking Fractional Obstacles will probably smooth out the surface depending on the ratio.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.