2
$\begingroup$

First time here, still pretty new to Blender.

I have an object that I've applied an image texture to. The object is a can with a label that wraps around 90% of it. The object's "label" texture requires two different material types:

  • A moleskin-like material with low refraction for the "background" of the label.
  • A semi-flat metallic material for some of the lettering and design elements on the label.

To achieve this, I used a principled BSDF and a glossy BSDF and fed them into a mix shader. I then added another image texture of the label "base" (acting as a mask for the metallic elements to come through) and fed the color output into the factor of the mix shader.

enter image description here

This effectively achieved the result I wanted, however, the transparent portion of the image texture (the non-metallic one) is showing up as black. I tried playing around with a transparent BSDF and an additional mix shader, but I couldn't figure out how to get it routed to be able to get rid of that pesky black.

enter image description here

I've been scouring the web for solutions but haven't made any headway. Any help would be greatly appreciated!

$\endgroup$
  • 2
    $\begingroup$ In your current setup the shader cannot know where to apply the transparency. You should connect the alpha output from the image texture node to the alpha input of your principled bsdf. This will only work if your png has an alpha channel correctly setup. $\endgroup$ – Gorgious Apr 28 at 7:28
  • $\begingroup$ I made sure my PNG had an alpha channel. I even went into the UV editor and switched around the alpha mode. When set to "straight" the black borders around the image do turn transparent (checkerboard) but when I plug the alpha output from the image texture into the principled BSDF's alpha input, nothing changes (that I can see). The black still remains. Is there something specific I need to do with my alpha when exporting the PNG? Thanks for the response! $\endgroup$ – Cleat J. Apr 28 at 7:39
  • 1
    $\begingroup$ Actually, I just figured it out! I noticed that after reconnecting the alpha in/out, the black area turned from having a slight highlight to completely black. So from there I went to my material properties' settings and switched the blend mode to "Alpha Blend" and it finally went away. Thank you for your help! $\endgroup$ – Cleat J. Apr 28 at 7:44
  • $\begingroup$ Don't add solved to your question title. Please add this is answer and accept it to help future visitors having the same issue. How this site works: blender.stackexchange.com/tour $\endgroup$ – brockmann Apr 28 at 8:17
  • $\begingroup$ Sorry about that. I wanted to mark Gorgious's response as the accepted answer, however, it was posted as a comment rather than an answer so I'm only able to upvote it. I read through the tour page thoroughly. If there's an alternative way to convert a comment into an accepted answer, I'm happy to learn as it's not mentioned anywhere in the page you linked. $\endgroup$ – Cleat J. May 6 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.