2
$\begingroup$

Blender was working fine a few days ago, but suddenly starting Blender up yields a screen like this. Screenshot of Blender on my system with its new glitch, the startup screen - for some reason - looks like the original image was wrung up into a twisted version of itself, diagonally skewed pieces of the view are stacked vertically within the window.

For some reason, the glitch doesn't occur when Blender is left free-floating: if I set it to fill the screen or either half of the screen, the glitch happens again. I can't get into system preferences or anything, either, because any pop-up from Blender has the same problem but irreversibly.

I don't know what changed. The only marginal thing I could think of is I installed a new library to my Anaconda IDE for Python, but I have the zipped Blender: they each have their own bundled version of Python.

I have a Windows 10 64-bit O.S., if that helps. But again, I don't know why this glitch is happening now when Blender was fine just a couple days ago. I have tried uninstalling and reinstalling Blender, but it doesn't help...

Edit: I have tried downloading a fresh copy from Blender's website; I've tried ZIP bundle AND msi executable downloads; I've tried multiple versions of Blender; and I have tried x32 vs x64 variants of each version. The glitch has persisted throughout.

$\endgroup$
  • $\begingroup$ Have you tried downloading a fresh copy? $\endgroup$ – Viplav Prakash Apr 28 at 3:21
  • $\begingroup$ @ViplavPrakash yes; in re-installing Blender, I downloaded a fresh copy from Blender's website itself. I even tried a more recent version of Blender, yet the glitch still happened. $\endgroup$ – Sampson Clyde Apr 28 at 5:53
2
$\begingroup$

everyone!

I'm the same person as the asker - had to make a new account because Stack Exchange said I hadn't used their email to confirm my email address (because I never got one).

I'm not sure why it was screwed up to begin with, but Blender works on my system now. I updated the drivers of my Display Adapters in the Device Manager.

| improve this answer | |
$\endgroup$
  • $\begingroup$ This also solved my problem. It's definitely a display adapter issue or something to do with the graphics card independent of Blender because I had the same issue for Photoshop as well. $\endgroup$ – AJ D. May 22 at 19:06
  • 1
    $\begingroup$ @AJD. I'm glad it helped! Weird that this sort of thing is affecting Creative Cloud as well... I wonder what makes them so similar. $\endgroup$ – Sampson Clyde May 23 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.