0
$\begingroup$

I have been modeling a dragon, and I see all sorts of artifacts in the mesh. When I go into edit mode and select all by trait, blender says they are non manifold and interior faces. I have researched many different ways of fixing bad geometry such as merge by distance, Weld modifier, and trying to smooth or use other tools in sculpt mode.enter image description here

Here is my .blend -->

$\endgroup$
  • $\begingroup$ Did you try select non-manifold operation and see what's going on that mesh? $\endgroup$ – HikariTW Apr 28 at 1:24
  • $\begingroup$ If it says "non-manifold" it means you have inner faces that need to be deleted. $\endgroup$ – Lukasz-40sth Apr 28 at 8:12
  • $\begingroup$ I had selected non-manifold, but the highlighted areas appeared to be "outer" faces and I did not want to delete those important parts of the mesh. I believe the artifact was caused by using the decimate modifier as described in Xylvier's answer. $\endgroup$ – ManlyDrew Apr 29 at 18:32
4
$\begingroup$

I looked over the file and found that over huge parts of the object there are faces overlapping other faces:
enter image description here

Some connected some not. While using a remesh modifier with a low enough voxel (roughly 0.08) size results in the geometry to be clean again:
enter image description here

The resulting mesh will have a throughout higher density and i do not know if you want to retopologize your dragon, as that might be the best way to reduce the density again.

I tried to use the decimate modifier and it actually resulted in similar artifacts, so retopo seems to be the best choice.

Another option going out from the version you shared, would be to cut away half of the dragon and using the mirror modifier. Then you would have to go over half the dragon and manually remove all the overlapping faces, believe me, it will be a good timekiller. Retopo seems in my humble opinion to be the better option.

Happy Blending

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.