0
$\begingroup$

I'm very new to blender, I'm following a tutorial to create a building. The viewport is set to shading, however it's showing the faces that should be out of view. I couldn't find a setting for this, mainly because I don't know what it is called. I tried Googling but I didn't know how to explain it.

How can I hide the faces that shouldn't be visible? See below:

My viewport:

This is my viewport

The viewport in the tutorial:

Tutorial

Version 2.82.7

$\endgroup$
3
  • $\begingroup$ maybe you've activated the Show Whole Scene Transparent button (on the right of the header menu bar, shortcut alt Z) $\endgroup$ – moonboots Apr 27 '20 at 22:05
  • $\begingroup$ That's the "Toggle X-Ray" option, this isn't enabled, toggling it on looks the same, just bolder edges. $\endgroup$ – user2924019 Apr 27 '20 at 22:09
  • $\begingroup$ This could be an issue with the drawing order due to the Blend Mode or perhaps backface culling is enabled and the normals point in the wrong direction. $\endgroup$ – Robert Gützkow Apr 27 '20 at 23:06
2
$\begingroup$

You probably have blend mode (in material settings) turned to alpha blend. It is used in Eevee for transparency, alpha blend mode tells blender that it will use alpha channel from texture to calculate transparency.

However even without texture with alpha you will see this overlaying faces effect when this setting is chosen.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks, this was the issue. It's a fresh installation, and the plugin I used was called "Import Images as Planes". Everything else was default so I'm not sure why this got turned to Alpha Blend. $\endgroup$ – user2924019 Apr 28 '20 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.