0
$\begingroup$

I am a complete newbee in blender. I created this object

enter image description here

and want to smooth the inner edge using bevel tool so I have something like that: enter image description here

But some artifacts in "Smooth shading" occured. What sould I do and how can I remesh my object to delete this strange artifacts?

$\endgroup$

1 Answer 1

0
$\begingroup$

Those artefacts come from the Smooth Shading option.

Each 3D object surface is made of triangles. Even when you work with quads or ngons, Blender will translate this into tris (for example each quad will be made of two tris). If you enable Smooth Shading, Blender will smooth every transition between 2 tris. It will give something good on round or flat topologies but it will give something bad on angular ones because Blender will also try to round the angle between hight-angled tris, which doesn't seem natural.

You can fix this with the Auto-Smooth option. It allows you to limit the smooth effect on tris that are only under a certain angle value. For example in your case if you set to a value under 90° it will smooth the round corner, because the tris angles are much under 90°, but it won’t try to smooth the 90° angle between the top and the side surfaces.

enter image description here

Apart from that, try to work with triangles and quads rather than ngons. Example:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .