1
$\begingroup$

enter image description here

I have attached volume scatter node to the world volume. So What I have right here is a super simple scene where the light is coming from a spot lamp and falling on the ground.

Ok so in this picture the left tab is my viewport and the right one is my render tab. You might have noticed how different two images really are. I wanted the same effect as in the viewport but even after increasing the number of samples does nothing for the actual render. What I have tried:

  • Increasing the number of samples(did not work)
  • decreasing the volume density(it's 0.001 btw)(worked but only for the viewport)
  • Increased Indirect light clamping(Did nothing for the render)
  • tried different angles(same result from each angle)

Please help me if you can by telling me what the issue is and how I can fix it

$\endgroup$
  • $\begingroup$ Increase the intensity of the light. $\endgroup$ – Pullup Apr 27 at 7:01
  • $\begingroup$ How many samples did you use at maximum ? $\endgroup$ – Gorgious Apr 27 at 7:06
  • $\begingroup$ 250 but no effect $\endgroup$ – Devansh Gupta Apr 27 at 7:28
  • $\begingroup$ actually that render came out with the spot lamp's strength at 100000W $\endgroup$ – Devansh Gupta Apr 27 at 7:39
  • $\begingroup$ can you tell me why the viewport render and the actual render are strikingly different? $\endgroup$ – Devansh Gupta Apr 27 at 7:41
2
$\begingroup$

There's a circle called circle.001 that you've parented to your lamp object (called Sphere). This circle obstructs your spot light. It won't cause any problem in the Viewport because you've disabled its visibility, but you've enabled it for Renders. So delete this object or disable its visibility for renders.

Also:

  • Reset the Compositor.

  • Don't use the Volume Scatter for the whole world, as you explain it looks like you can't use any other light than Spots if it's assigned to the whole world. Instead, create a cube that encompass your scene and give it the Volume Scatter node.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks man you have literally saved my day $\endgroup$ – Devansh Gupta Apr 27 at 15:26
  • $\begingroup$ but seriously now that I know where I was wrong(thanks to you) I feel like stupid $\endgroup$ – Devansh Gupta Apr 27 at 15:38
  • $\begingroup$ no problem, it was not obvious, I just made an unhide to make sure something was not hiding the light, then I had to find the object, it was kind of hidden in the Outliner as well as it was the child of another object ;) $\endgroup$ – moonboots Apr 27 at 15:43
  • $\begingroup$ yeah but thanks anyway man $\endgroup$ – Devansh Gupta Apr 27 at 16:18
  • $\begingroup$ No, NO I just found out that volumetric scattering works only with the light which comes off spot lamp and no other light source will show any effect while in presence of volumetrics. docs.blender.org/manual/en/2.79/render/blender_render/lighting/… $\endgroup$ – Devansh Gupta Apr 27 at 17:04
0
$\begingroup$

Try using the Intel denoiser in compositing.

Under [View Layer Properties -> Passes -> Data] check the box for "Denoising Data". Then in the compositor, connect the noisy image slot with the image slot in the "Denoiser" filter. This works pretty well for me.

Also increase the light intensity.

| improve this answer | |
$\endgroup$
  • $\begingroup$ have already tried it and got just a like less grainier picture which is completely flat or in simple words it didn't help at all in fact made the matter worse. BTW thanks $\endgroup$ – Devansh Gupta Apr 27 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.