0
$\begingroup$

I am trying to do a simple smoke simulation using the Quick Smoke effect and the problem I am running into is that although my smoke shows and animates fine on preview, when I start rendering it just stays still, a big smokey blob around my emitter object. It appears to be simply rendering Frame 1 of the smoke in each frame.

I have tried to bake the animation in my Smoke Domain and my Emitter object ( because I don't honestly understand which is the one that 'owns' the smoke in this regard ) and save the project afterwards but that didn't change anything.

view with smoke as blob

This is the only frame that appears to get animated. The behaviour is the same between Eevee and Cycles so I assume it is something I'm doing wrong.

My smoke domain looks like this:

Smoke domain illustration

What do I need to add or change in order for my animation to behave the same way in render that it does in preview?

$\endgroup$
4
  • 1
    $\begingroup$ Set it to Modular/Final and bake it again. Replay bakes everything live. $\endgroup$
    – Yohello 1
    Apr 26, 2020 at 16:12
  • $\begingroup$ @Yohello1 if you make that an answer- perhaps with a bit of explanation of why - I'll accept it. $\endgroup$
    – glenatron
    Apr 26, 2020 at 20:26
  • 1
    $\begingroup$ Sorry. I usually do comments and don't often do answers because most people are looking for a fix not a for the reason why it happened. Tell me if I need to add any more. $\endgroup$
    – Yohello 1
    Apr 26, 2020 at 22:19
  • $\begingroup$ I've been using various SE sites for a long time and I know someone else will run into this problem sooner or later so a real answer will help them as well. You solved my problem and you definitely deserve credit for it. Thank you. $\endgroup$
    – glenatron
    Apr 26, 2020 at 23:11

1 Answer 1

1
$\begingroup$

This also apply's to fluid simulation. Do not change the file format it will cause more issues than you can count

There is one key reason why it will not show in render(Don't worry all the settings are fine) the reason is the "Type" under cache is set to "Replay".

The type replay is typically used for quickly making smoke simulation and finding laws quickly and will bake while the animation is playing in view port. But this is not like the old smoke simulation engine where just playing the animation thing in view port will bake it properly and save it to disk. Because the simulation data is not saved to disk when you go to render it it will have no information about where the smoke is or anything about it (you can say it's in ram but Blender won't use that). Therefore it will render nothing or the same data as the last one used(last frame con occur due to other things) it will normally render nothing.

There is an easy fix for this to set the Cache type to Modular ,or Final. enter image description here

Modular = Independently bake everything, bake the smoke then the noise then anything else

Final = Bakes everything at once for this one simulation, I do not suggest using this because one issue in the actual smoke simulation can make you bake the entire thing again

Do not change the file format

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.