5
$\begingroup$

I have a problem, or rather found a limitation in eevee that when an object is too close to a light, volumetrics will show in front of the object, like here

enter image description here

I would really appreciate if anyone could tell me where is a setting (because there must be one!) to control in what minimal distance do volumetrics clip through other objects.

That said the object in the screenshot is solidified - there is room for the spotlight like so:

enter image description here

in material settings everything is set to opaque and I have tried everything that came obvious to me like checking normals.

$\endgroup$
1
  • 1
    $\begingroup$ Render tab > Volumetrics, try decreasing the End value a whole bunch. $\endgroup$
    – BuzzKirill
    Aug 27, 2020 at 5:56

4 Answers 4

2
$\begingroup$

Found a fix, go to Render Properties > Volumetrics and increase samples to 128 or higher.

$\endgroup$
0
$\begingroup$

For the render view, you have to play around with Start and End distance of volumetrics depending on the distance of representation and on the distance your camera is positioned. It's gonna be different for every case.

$\endgroup$
0
$\begingroup$

None of the other methods worked for me. What I did was I increased the radius of the spot light.

It will dim the light. Then I increased the power to compensate for it.

$\endgroup$
-1
$\begingroup$

I have found that increasing the samples does not always work. We fixed this by removing "Volumetric Lighting" from the volumetrics settings (I had the same problem on another project).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .