0
$\begingroup$

I have a setup where I have one collection that is a background and one that is silhouetted against it. Each of these is in it's own View Layer. The background one rendered straight, the foreground one is lit brightly, rendered and then inverted.

My World is a starfield generated from a noise texture. The problem is that if I have world enabled, the inverted foreground layer creates an inverse starfield, completely blanking out the background layer.

I have found a few questions around this topic ( for example 'One render layer with background image and one with transparent background' ) but they are old and they talk about enabling environment rendering which doesn't seem to exist any more.

So, in Blender 2.8 how do I render my world once rather than once-per view-layer?

$\endgroup$
2
  • 2
    $\begingroup$ The principle is the same. Create a new View Layer, disable all collections (right-click > View layer > Disable from View Layer) and render. For all other layers set Film to transparent... $\endgroup$
    – brockmann
    Apr 25 '20 at 13:31
  • $\begingroup$ @brockmann then combine at render using alpha-over? $\endgroup$
    – glenatron
    Apr 25 '20 at 14:34
2
$\begingroup$

You can get precisely what you want by creating a dedicated, empty background render layer with an environment pass.

1.) Under "Render properties" on the "Film" panel select "Transparent". All of your current layers will now render a transparent world background.

2.) Create a new layer and disable ALL collections in the Outliner. In the "View Layer Properties", enable an environment pass.

3.) Now in the compositor, use an "Alpha Over" node to put everything above the "Env" channel of the background layer we just created.

$\endgroup$
0
$\begingroup$

You could use scenes instead of view layers, render, and combine; with scenes you could also use a different render engine.

enter image description here

If you have doubts you could watch this video https://vimeo.com/346386958

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.