0
$\begingroup$

So I need to create a personal project for my Gaming Concepts class so I decided to make some new models in Blender. When I imported the FBX file, parts of the model was missing textures and was transparent on edges, and some parts are clipping. Anyone know how to fix this? Unity view of model with parts missing. Blender view of what model is supposed to look like.

$\endgroup$
3
  • $\begingroup$ The simpliest way if you create the shader in Unity and not export it. The clipping is caused by wrong face directions, you have to flip those face normals in Blender. If you switch to solid view and turn on backface culling you will see the clipping faces in Blender too. $\endgroup$ – FFeller Apr 22 '20 at 18:07
  • $\begingroup$ Is there a way to export the shader seperately from blender? $\endgroup$ – Omar Apr 23 '20 at 0:54
  • $\begingroup$ The Blender shader not compatible with Unity. In the best case you will see the textures in the file. Just create the shader in Unity with the texture files. $\endgroup$ – FFeller Apr 23 '20 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.