2
$\begingroup$

I'm using Blender 2.8, doing retopo for a sculpted model with Shrinkwrap modifier and sometimes enabling Snap. Some of my vertices have their pivot oddly offset and it's making the shrinkwrap modifier perform badly.

As you can see in the screenshot here, I have selected a vertice but the actual pivot to move it around is off to the side and below it. This is not the case for all of my vertices, and does not change if I switch between different pivot point "styles" (individual origins/median point/etc.)

How do I fix this and "reset" the transformation center to be right on the vertex itself?

enter image description here

$\endgroup$
1
$\begingroup$

This happens, because Gizmo doesn't take modifiers into account.

According to this developer thread and this developer thread it's a current limitation, and no way around that.

enter image description here

$\endgroup$
3
  • $\begingroup$ Okay, what's the solution then? I need to be using the "on cage" option. Should I apply the shrinkwrap modifier and then make another one? $\endgroup$ – Ollie Apr 22 '20 at 13:27
  • $\begingroup$ @JachymMichal Why are you asking the user to accept the answer before they've indicated that it's helped? (And if they had a subsurf on it why aren't the edges curved at all?) $\endgroup$ – Ray Mairlot Apr 22 '20 at 16:05
  • $\begingroup$ @RayMairlot You're right, i'll remove that :). The OP isn't using Subsurf, but Shrinkwrap. The problem isn't with a specific modifier, but with Gizmo ignoring all modifiers. $\endgroup$ – Jachym Michal Apr 22 '20 at 16:10
0
$\begingroup$

For anyone looking for an actual answer instead of waiting for a new Blender version - apply the existing Shrinkwrap modifier, then add a new Shrinkwrap Modifier. This fixes the issue immediately.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.